Connect with us

GPS - Module Jupitor 31 - Navman Not getting valid data

Discussion in 'Microcontrollers, Programming and IoT' started by rajeesh, Jul 7, 2010.

  1. rajeesh

    rajeesh

    1
    0
    Jul 7, 2010
    Hi,

    I am using at91rm9200dk board
    I am using Jupitor 21 Gps module it is working fine
    Then I changed the GPS module to high performance one Jupitor 31 .
    Now I am not getting valid data.

    Please see the data I am getting from gps via serial port
    Any body have the hardware connection of Jupitor 31 please send me
    Please help me.

    $GPGGA,235949.054,,,,,0,00,,,M,0.0,M,,0000*57
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPRMC,235949.054,V,,,,,,,070707,,*29
    $PRWIZCH,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0*4D
    $GPGGA,235950.049,,,,,0,00,,,M,0.0,M,,0000*53
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPGSV,3,1,12,20,00,000,,10,00,000,,31,00,000,,27,00,000,*7C
    $GPGSV,3,2,12,19,00,000,,07,00,000,,04,00,000,,24,00,000,*76
    $GPGSV,3,3,12,16,00,000,,28,00,000,,26,00,000,,29,00,000,*78
    $GPRMC,235950.049,V,,,,,,,070707,,*2D
    $PRWIZCH,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0*4D
    $GPGGA,235951.045,,,,,0,00,,,M,0.0,M,,0000*5E
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPRMC,235951.045,V,,,,,,,070707,,*20
    $PRWIZCH,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0*4D
    $GPGGA,235952.051,,,,,0,00,,,M,0.0,M,,0000*58
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPGSV,3,1,12,20,00,000,,10,00,000,,31,00,000,,27,00,000,*7C
    $GPGSV,3,2,12,19,00,000,,07,00,000,,04,00,000,,24,00,000,*76
    $GPGSV,3,3,12,16,00,000,,28,00,000,,26,00,000,,29,00,000,*78
    $GPRMC,235952.051,V,,,,,,,070707,,*26
    $PRWIZCH,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0*4D
    $GPGGA,235953.048,,,,,0,00,,,M,0.0,M,,0000*51
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPRMC,235953.048,V,,,,,,,070707,,*2F
    $PRWIZCH,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0*4D
    $GPGGA,235954.049,,,,,0,00,,,M,0.0,M,,0000*57
    $GPGSA,A,1,,,,,,,,,,,,,,,*1E
    $GPGSV,3,1,12,20,00,000,,10,00,000,,31,00,000,,27,00,000,*7C
    $GPGSV,3,2,12,19,00,000,,07,00,000,,04,00,000,,24,00,000,*76
    $GPGSV,3,3,12,16,00,000,,28,00,000,,26,00,000,,29,00,000,*78
    $GPRMC,235954.049,V,,,,,,,070707,,*29
    $PRWIZCH,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0,00,0*
     
  2. davenn

    davenn Moderator

    13,264
    1,749
    Sep 5, 2009
    Hi Rajeesh

    I do play with GPS units a little. I mainly use them for a source of an accurate frequency that I can lock a 10MHz oscillator to.
    I have dabbled with the NMEA data string from the Jupiter T receiver boards, its not too dificult to decode and display date time location etc on a small LCD screen.

    In your case I'm wondering if the data string from the Jupiter 31 is slightly different to the 21 receiver and thats why the code in your MCU isnt recognising what it is seeing.
    You may need to do some investigating to see what differences there are between your 2 receivers and alter the code in the AT91xxx to suit

    cheers
    Dave


    the data below.... is that from the 21 or the 31 ?? have you compared them both yourself ?
    what differences can you see ??

     
    Last edited: Jul 8, 2010
  3. davenn

    davenn Moderator

    13,264
    1,749
    Sep 5, 2009
    Hi Rajeesh,

    no posts from you for a few days..... have you read the data stream from the other GPS unit yet. If so how did the 2 of them compare ?

    Dave
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-