Connect with us

Gould OS1200 Oscilloscope - Intensity not working

Discussion in 'Troubleshooting and Repair' started by warf135, Sep 2, 2011.

Scroll to continue with content
  1. warf135

    warf135

    28
    0
    May 21, 2011
    Hi, This is a Gould OS1200 Oscilloscope, which seems to be fully working, apart from the intensity control not working, therefor the trace is not very bright.

    Service Manual

    [​IMG]

    I have cleaned and checked R780. The -12v supply at R768, 12v supply at R769 and the 120v supply at R773 are all good. Resistors R781, R763, R768, R769 and R773 are all ok. Diode D711 tests ok as does TR725 and TR726.

    I have replaced most of the electrolytic caps on the board too as they were showing signs of age.

    Any Ideas?

    Norm (aka Warf135)
     
    Last edited: Sep 2, 2011
  2. warf135

    warf135

    28
    0
    May 21, 2011
    UPDATE: Transistor TR723 - BC450 is blown... BC450 is hard to find, Anyone know a suitable, readily availible replacement?
     
  3. warf135

    warf135

    28
    0
    May 21, 2011
    TR723 (BC450) replaced with BC640 (with legs swapped round) and intensity still not working.

    TR721 was found to have been replaced before and incorrectly fitted, so I removed, tested and re-fitted that correctly, but still the intensity control refuses to work...

    Any ideas?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-