Connect with us

Genie/Astable help

Discussion in 'Microcontrollers, Programming and IoT' started by Curtis555, Mar 13, 2016.

Scroll to continue with content
  1. Curtis555

    Curtis555

    3
    0
    Mar 13, 2016
    I have an astable pulsing at 1000hz being passed into a genie input, the program increments a variable every time the pin goes high and I was trying to use this as a way of creating a millisecond timer. It works perfectly fine in simulation but when debugging whilst running in practice the circuit fails. Both sub-systems work perfectly fine individually but interfacing them is a problem. Any help would be great, thanks!
     
  2. Alec_t

    Alec_t

    2,962
    803
    Jul 7, 2015
    Show us how you have them interfaced.
    Welcome to EP!
     
  3. Curtis555

    Curtis555

    3
    0
    Mar 13, 2016
    Thank you! It's just when a switch is pressed the genie will enable the astable which begins pulsing, the output of the astable connects back onto a genie input. It seems to work when I slow the astable, I thought the genie was quick enough to process 1khz on an input.
     
  4. Alec_t

    Alec_t

    2,962
    803
    Jul 7, 2015
    I know nothing of the Genie's capabilities, but virtually every modern MCU/processor made should find 1kHz a doddle ....providing, of course, it has been properly programmed.
     
    Arouse1973 likes this.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-