Connect with us

fluorescent torchier ballast

Discussion in 'Electronic Repair' started by James Sweet, Dec 4, 2004.

Scroll to continue with content
  1. James Sweet

    James Sweet Guest

    A friend gave me one of those nice torchier lamps that uses a GE 55W 2D
    fluorescent lamp. It wasn't working so I opened up the ballast and fixed a
    few cracked solder joints but still no go, then I found that there's a
    number of places in the circuit where if I touch a test lead to it with
    power applied the lamp fires right up and will run normally all day from
    there. It's definitly electrical because I soldered a length of wire to it
    and running my hand over the insulated wire will usually start the lamp.
    I've checked all the active components and they seem ok, checked most of the
    passives, including ESR on the electrolytics and everything seems to be in
    order. Anyone ever run into this before?
     
  2. Bill Jeffrey

    Bill Jeffrey Guest

    Sounds like a ground problem - or rather a lack-of-ground problem.

    I don't know about torchieres, but in common fluorescent fixtures with
    the straight 4-foot tubes, the starting behavior sometimes depends on
    having a good ground connection in place. If the ground is cut,
    interrupted, or missing, the tubes won't start.

    So, have you converted a three-wire cord to a two-wire plug using a
    3-to-2 adapter, or anything similar? Have you checked the polarity at
    the outlet? Are there any screws missing on the ballast PC board, which
    might have provided a ground connection or connection to the case or
    body of the lamp? If it is the original two-wire plug, have you tried
    reversing it in the socket?

    Just a thought ...

    Bill
    =====================
     
  3. James Sweet

    James Sweet Guest


    Actually I finally figured it out. These solid state CFL ballasts don't
    require grounding, the lamp never had a 3 wire cord on it. Turned out to be
    a 2.2uF lytic rated at 100v. The 15 ohm ESR is about what I measured on a
    new 100v cap so I had overlooked it, but then later I realized this cap
    filters the power rails to an IC with a max rating of 18v. Replaced it with
    a 3.3uF 35v cap and the lamp works perfectly. Guess they got a real good
    deal on 100v capacitors. With the faulty capacitor the supply wasn't stable
    enough for the oscillator to run properly.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-