Connect with us

Fluke 8846A Repair

Discussion in 'Troubleshooting and Repair' started by vraftsman, Jan 22, 2013.

Scroll to continue with content
  1. vraftsman

    vraftsman

    2
    0
    Jan 22, 2013
    I need some help in diagnosing my multimeter. The Fluke 8846A is a benchtop DMM which functioned normally for about a year. Then it started giving me incorrect readings and in some cases no readings. Some instances I have tested are: resistance, shows correctly but only certain values in the Mohm range so precision is lost. I tried taking readings of a standard household outlet and in freq mode it switches back and forth from “overload” to correctly showing about 60hz, in VAC mode it shows .018 which is clearly wrong and something like .032 when the leads aren’t even attached. The temp mode doesn’t show anything when hooked to the appropriate TC. I opened it up and didn't see any obvious problems and both the replacable fuses are intact, it looks pretty sophisticated, ie: not too many parts I will be capable of replacing. My thought though is that since it is taking correct readings in some modes and maybe just the wrong decimal in others, it’s not too screwed up but Fluke wants $500 to repair it without even going through a diagnostic process! I can’t spend that kind of money so I was hoping someone in a forum would have an idea of what to do. Thanks in advance for any input!
     
  2. quantumtangles

    quantumtangles

    152
    3
    Dec 19, 2012
    Causation. This DMM has a three pin mains power supply = it is grounded.
    However, you used it to test mains AC devices which may also have been grounded to a common earth. If the DMM as well as the device under test were both unintentionally connected to your mains household earth, such a completed 'common earth' circuit could have caused a melt-down of the DMM. Many an oscilloscope has been destroyed in that way, but you probably would have noticed a loud noise etc. Accordingly, someone else may have been using your DMM without your knowledge.

    Another candidate explanation may be that the voltage setting (at the back of the DMM) has been accidentally flipped from 240 to 120 or vice versa, and is simply on the wrong setting at the moment. Unlikely.

    I would also check the pins, for example on the IEEE488 and RS-232 connectors (back panel) just in case someone tried to cram something square into a round hole :D

    If you post clear photos of the circuit board, that will help the serious minds here diagnose and solve the problem (I am not one of the serious minds). For sure, they will need further information.
     
  3. vraftsman

    vraftsman

    2
    0
    Jan 22, 2013

    Thanks Quantum, I did check the ports all around an nothing looks out of the ordinary. I double checked that the input selector is set to 120V. I do not have experience with the oscilloscopes but when you mention a loud pop I assume that would be a power transistor or electrolytic capacitor, but all of those look ok to me. I will post some HQ pics soon and hopefully someone else will have an idea. Thanks for your input.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-