Connect with us

Fluke 8842A ROM binary

Discussion in 'Electronic Equipment' started by JW, Sep 28, 2010.

Scroll to continue with content
  1. JW

    JW Guest

    Hello,

    Looking for a Fluke 8842A ROM binary. Chip is a 2732A and is located in
    U222 near the input filter. It is a socketed part. This one is gone bad,
    and the A/D watchdog keeps resetting the micro. Tried a 8840A ROM, and
    while the meter comes up and runs, all the readings are high by order of
    10. Reading the ROM using a variable voltage supply didn't get the job
    done, but interesting to note that that has worked at times in the past
    for me.

    Thanks for any help/leads.

    Jay
     
  2. If you get no help here you could try joining the Tech Tools mail list
    and posting there. Email me for the link - a small group of
    video/pinball techies that help each other out with test gear.

    I suspect there are Fluke forums out there though that might work better.

    I don't have the meter in question.

    John :-#)#

    --
    (Please post followups or tech inquiries to the newsgroup)
    John's Jukes Ltd. 2343 Main St., Vancouver, BC, Canada V5T 3C9
    Call (604)872-5757 or Fax 872-2010 (Pinballs, Jukes, Video Games)
    www.flippers.com
    "Old pinballers never die, they just flip out."
     
  3. tm

    tm Guest

    Hi Jay,


    Did you ever find a copy of this ROM? If not, I have an 8842A and can copy
    the ROM. I am in need of a copy of the 8840 ROM if you still have it.

    Regards,
    Tom
     
  4. JW

    JW Guest

    Correction: Actually the readings were off by a magnitude of 100.
    Hi Tom,

    Yes, I still need it. Check your email, I sent the 8840A binary to your
    valid email address. You can send the binary to my Yahoo account.

    Thanks, I'll be glad to get this meter off my repair shelf.
     
  5. tm

    tm Guest

    Hello John,

    I am jumping in here to add to Jay's request. He is working on a 8842A. I
    have a 8842A/AC and sent him a copy of the ROM. Unfortunately, it did not
    work as mine was a different version. He sent me the code for the 8840A but
    it did not work either as the unit I have is the 8840A/AC.

    Bottom line is we are both looking for ROM images for different versions.
    You mentioned the tech group that may be of help. Could you let Jay or me
    know that info? My address is tmiller - at - skylinenet . net.


    Best regards,
    Tom
     
  6. JW

    JW Guest

    Hi Tom,

    I just did a binary compare between the ROM that was in my 8842A and the
    binary you sent me. They match. So it looks like my ROM is not bad, but
    somebody has been screwing around in this unit before I got it. I suspect
    that the micro-controller was swapped, and that the one that was put into
    it is a incorrect version (It is marked V2.3)

    The spare piggy-back Z8 I have lying around also has a V2.3 ROM installed
    on it. If you can find a Z8 I could send you the matching 2.3 code that
    goes into the 2732 chip, giving you both a U222 V2.3 and a micro version
    2.3. If your meter begins working then that would go a long way in
    figuring out whether the code in both chips must be the same revision.
     
  7. tm

    tm Guest

    Hi Jay,

    I started a thread up on the Tekscopes group about this topic. You might hop
    over there and add to the discussion. It seems there are several versions of
    the Z-8 firmware and they don't match the EPROM versions.

    Tom
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-