Connect with us

External soundcard damaged

Discussion in 'Troubleshooting and Repair' started by Psihobambi, May 31, 2015.

Scroll to continue with content
  1. Psihobambi

    Psihobambi

    1
    0
    May 31, 2015
    Hi, my Audiobox USB external soundcard suddenly stopped sending left output signals. To be exact it only sends them within a certain dB area. http://postimg.org/image/p6glhom8r/

    When I try to twist the main knob a bit more, only right speaker works.(I've tried switching cables, so that sound from the left stereo field (left output) goes to the right speaker, and the exact same thing happens. Just to the right speaker.) http://postimg.org/image/yb0ibp6dd/

    http://postimg.org/image/br382x1qz/
    I've tried pushing that metal thingy inside a L output hole a bit with a screwdriver, and it solved my problem for an hour or so.

    http://postimg.org/image/4a37f6qzf/

    http://postimg.org/image/g5nlravcb/

    I am new here. Didn't find a thread that resembles my problem. Hope this is the right sub for this.

    *I already tried putting some medicine alcohol on the knob.
     
  2. Harald Kapp

    Harald Kapp Moderator Moderator

    10,778
    2,433
    Nov 17, 2011
    Welcome to electronicspoint.
    I doubt the controls are the problem.
    This sounds like a bad contact in the output connector. Get a new socket in exchange for the broken one.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-