Connect with us

Extech MM560 - Micronta 22-167 Shootout

Discussion in 'Electronic Equipment' started by Anthony Fremont, Mar 6, 2007.

Scroll to continue with content
  1. Got my new Extech MM560 today, pretty cool. Haven't had much opportunity to
    play with it much yet, but I did a few measurements just to see how the 15
    year old Micronta was holding up.

    On an old 6V battery I use for tinkering I get this.
    Extech: 5.833V
    Micronta: 5.98V (2.5% high)

    Plugged into the wall:
    Extech: 123.61V
    Micronta: 124.9V (1% high)

    Running PIC Current:
    Extech: 1.387mA
    Micronta: 1.40mA (<1% high)

    Sorry, no resistance or really low current measurements yet. I do see that
    the power company is running the mains at anywhere from 59.9xxHz to 60.0xxHz
    though constantly sliding around. :)

    Concerns: Build quality seems decent enough. The probes are certainly
    nicer than the Micronta, but we'll have to see how they look after 15 years.
    ;-) The meter looks good so far, but it is different from what I'm used to.
    When you first set to a uA or mA mode, there is a residual charge of some
    sort that counts down for a minute and then settles down to below a count of
    8-10 (starts out around 400). Shorting the probes makes no difference, you
    just have to give it a minute to settle down. Is that normal?

    Does anyone else think it odd that the battery was already installed?
     
  2. Ben Jackson

    Ben Jackson Guest

    Thermal converter for the True RMS? :)
     
  3. I called Extech about it, they said they didn't think that the meter should
    be doing that, especially since shorting the probes makes no difference, but
    the fuse is fine. I'm taking their advice and contacting Mouser about it to
    see what they want to do. After another five or ten minutes, the count
    hovers around 4. It really does act like something is heating up, except
    that turning it off and right back on starts the process over. Strange how
    it's completely independant of any measuring you're doing. I guess it's a
    cap/voltage/charge thing affecting some ADC reference chip or something. I
    just emailed Mouser's tech suport arena, we'll see what they say.
    Disappointing to say the least. :-(

    If everybody wanted to be really gentelmanly now, they could send me a meter
    with an NIST cert. ;-)
     
  4. Everybody, of course meaning Extech and Mouser. :)
     
  5. ehsjr

    ehsjr Guest

    Sorry to hear it - what a PITA.

    Maybe they each should end you one of each (w/without the
    NIST) so you can compare and see how they should behave. :)

    That's a nice looking meter from the specs - thanks for
    posting the url in the other thread. It has a very large
    "drool factor". Somehow I couldn't find that on the
    spec sheet! :)

    Ed
     
  6. It'll be a hassle sending it back, but oh well. It still seems to work fine
    outside of that little issue. I'm most surprised that my old meter has held
    up as well as it has.
    I figured they could at least send me a certified one so we could all feel
    good knowing it would be right this time?
    ;-)
    It's not quite as flashy as a bright yellow Fluke or a firey red Wavetek,
    but it ain't bad. Decent specs and for the money it seemed the best deal.
     
  7. MassiveProng

    MassiveProng Guest


    Should have spent $150 and bought the used HP, which is likely to be
    an order of magnitude more accurate, and more reliable, and less
    likely to drift over time.

    PERFECT for long term home use without the need for a yearly cal
    session!

    Bwuahahahahahahaha!
     
  8. MassiveProng

    MassiveProng Guest


    He is probably using the 4 to 20 mA scale which is NOT for current
    measurement, but for process instrument measurement.

    It RESTS at 4! & EXPECTS 4 as a baseline Minimum! D'oh!

    Took me all of 6 seconds looking at the data sheet.
     
  9. I know how to take current measurements, and I know how to use a meter in
    general. Reread the post til you understand that the count starts at 400ish
    (4.xx mA in mA mode, 4.xx uA in uA mode) and drifts down to around 4 (0.04mA
    or 0.04uA) and that shorting the probes has no effect at all. It has
    nothing to do with process measurements or current loops either. If you'd
    have spent another 6 seconds, you would have realized that process current
    loop measurements are displayed as percentages, not ordinary mA or uA.

    I talked to Extech about it and they think that it's a defective meter.
    They said to send it back.
     
  10. DC or AC range?

    The lower DC ranges on higher spec meters often have Gohm input
    impedance which pick up noise, but goes away instantly when you short
    the probe.

    Dave :)
     
  11. How many times do we have to go thru this? I need/want a portable meter,
    not a bench meter. I need/want .01uA resolution, not 1uA resolution. Other
    than that, I'm sure it's a fine meter. That's why the 3478a is not the only
    thing made.
     
  12. You don't get it do you? People buy a hand held meter for many good
    reasons, a big bench meter is not an option for them.

    Dave :)
     
  13. Shorting the probes has no effect. :-( Oddly enough, it only does then
    when you have AC+DC (which was apparently the default) or just AC selected.
    If you select DC only then it seems fine. OTOH, if you select only AC
    current, it does the countdown thing, only slightly differently (it takes
    the same amount of time to get down near zero, it just updates the display
    several times/second instead of once every couple of seconds). Strange. I
    wish someone else had one and could tell me there experience.
     
  14. Sorry, thought you were talking about the voltage range :-/

    My Fluke 87III does the same thing on the uA and mA AC current range.

    In the 4.5 digit uA mode it starts out out around 2.8uA and slowly
    settles down over about 30 seconds to around 0.18uA and won't go
    lower.
    In 3.5 digit mode it starts around 3.5uA and drops to around the same
    0.1-0.2uA, but it's faster than the 4.5 digit mode.
    mA range is similar with a residual offset of around 1.8mA

    Obviously the True RMS converter has some settling time, and a
    residual offset which you can null out, but it takes time again to
    settle down to zero after the null.

    DC is of course fine as there is no True RMS converter to deal with.

    I don't think there is anything wrong with your meter, it's fairly
    normal for True RMS meters.

    Meters without True RMS don't exhibit this problem, they just go to
    zero straight away and sit there.

    Dave :)
     
  15. No, it's the True RMS converter.

    Dave :)
     
  16. You don't know your own equipment again! - check your beloved Protek
    506, it does a similar thing. Takes almost 30 seconds to settle down
    to zero on AC current, but it does get to zero, no apparent offset.

    Dave :)
     
  17. I wonder why the tech support guy didn't snap to that? I guess he probably
    figured I had it in straight DC mode.
    Ok then, I may keep it for a while and see how it does. It certainly seems
    accurate. It has a 3yr warranty, and it certainly seems like Extech is
    willing to stand behind their product. I just did some tests and sure
    enough in DCV mode if I press SELECT and chose RMS, it does the same kind of
    thing. It takes almost two minutes to really settle out. I don't think I
    like that, but it sounds like it is par for the course. Really updates the
    display slowly doing RMS measurements too (like once every two seconds).

    I just did a couple of resistance measurements:

    1M resistor
    Extech: 1.0195M
    Micronta 1.020M (.05% high)

    390R
    Extech: 394.44R
    Micronta: .395K (.14% high)

    I don't know, but I think my Micronta is not too shabby.
     
  18. Yeah, or they might simply follow the "customer is always right"
    policy, and just wanted to keep you happy.
    I'm not really a huge fan of True RMS meters, they are slow and
    generally not as accurate as normal meters. If you *know* you have a
    sinusoidal signal then a normal meter is better.
    Switchable true RMS would be nice!
    It's not, it's a perfectly fine meter for general use.

    Dave :)
     
  19. They certainly didn't make me unhappy by that. Now Mouser on the other
    hand........... e-mail to tech support at 11:00am yesterday, not a peep. I
    guess they aren't much on e-mail. I'm going to go ahead and keep it for
    now, at least until I have reason to suspect that something really is wrong
    with it.
    Sure does give really slow updates (seconds between each one). I'm glad I
    don't have to use it unless I need it.
    I looked around some of the cal sites and in some places it's one of the
    very few radio shack models they will even look at. This seems to be an
    almost exact copy of it:
    http://www.tequipment.net/EZDigitalKD3220.asp. The pc board has KD-3200C
    stamped on it. Awful cheap now compared to when I bought mine.

    I sure wish my scope would hurry up and get here. :)
     
  20. I like that it uses the same jack for V/ohms and uA/mA, no lead
    swapping.

    What's the build quality of the Extech like inside?
    Photos?
    Was that the 1000 series Rigol ?

    Dave :)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-