Connect with us

ESP8266 Programming Error

Discussion in 'Microcontrollers, Programming and IoT' started by _Nate_, May 19, 2018.

  1. _Nate_

    _Nate_

    99
    0
    Jun 12, 2017
    So I've been trying to at least run a successful "Blink" code for my esp-01 module (using this usb tool), but I get the same error every time:

    Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), Board: "Generic ESP8266 Module, 80 MHz, ck, 26 MHz, 40MHz, DIO, 1M (64K SPIFFS), 2, v2 Lower Memory, Disabled, None, Only Sketch, 115200"

    Archiving built core (caching) in: C:\Users\XXXXX\AppData\Local\Temp\arduino_cache_994175\core\core_esp8266_esp8266_generic_CpuFrequency_80,ResetMethod_ck,CrystalFreq_26,FlashFreq_40,FlashMode_dio,FlashSize_1M64,led_2,LwIPVariant_v2mss536,Debug_Disabled,DebugLevel_None____,FlashErase_none,UploadSpeed_115200_556dd2950946f279e9b4b76b952dace8.a
    exec: "{runtime.tools.esptool.path}/esptool.exe": file does not exist
    Error compiling for board Generic ESP8266 Module.


    I have looked into this error extensively and downloaded the esptool.exe file to place in this directory:

    C:\Users\XXXXX\Documents\ArduinoData\packages\esp8266\hardware\esp8266\2.4.1\tools\esptool.exe

    I have added this program to exceptions in Windows Defender and such, to no avail. Any help would be appreciated.
     
  2. Hopup

    Hopup

    227
    31
    Jul 5, 2015
    If u google with information "Error compiling for board Generic ESP8266 Module.", you can find lot of information.

    You might need latest version of the code, https://github.com/esp8266/Arduino/tree/07f4d4c241df2c552899857f39a4295164f686f2.

    EDIT: This could also work "

    In Arduino IDE Go to:

    Sketch -> include libraries -> manage library and search all type all topic for "esptool" then click install

    Done."
     
    Last edited: May 19, 2018
  3. _Nate_

    _Nate_

    99
    0
    Jun 12, 2017
    I tried installing the library and updating the arduino package, and even moving the esptool.exe from the esp8266 folder to the arduino folder did not work.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-