Connect with us

Epson scanner returns blank scans

Discussion in 'Electronic Repair' started by John E., Feb 11, 2007.

  1. John E.

    John E. Guest

    Epson Perfection 1670 used to work fine. Now when I scan a document (any
    document) I get a white page. The scanner responds to all commands from the
    software (it will preview and scan when tasked), and I've tried all different
    settings. I've tried different software, too (the Epson Twain software, and
    VueScan). No joy.

    The FAQ at the Epson page for this scanner says that the scanner "may not
    work properly" if a USB cable other than an Epson cable is used. What cable
    should I use? I've been using one that I usually use for my Canon inkjet
    printer. The scanner has one of the square 4-pin USB connectors, and the
    cable is the flat 4-pin to square 4-pin ones.

    Power supply "brick" is providing correct voltage.

    Ideas?

    Thanks,
     
  2. Arfa Daily

    Arfa Daily Guest

    Is the scanner lamp lighting ?

    Arfa
     
  3. Meat Plow

    Meat Plow Guest

    So does it provide a correct preview of the document scanned?
     
  4. If is wasn't, wouldn't you expect a *black* image rather than a white
    one? Besides, the OP says he does see a preview, and you can't make a
    preview if your lamp doesn't work.
     
  5. 3T39

    3T39 Guest

    Hello, John!
    You wrote on Sun, 11 Feb 2007 01:25:46 -0800:

    If you can see a preview then the scanner is probably OK, the main issue
    will be software related. You are probably inadvertantly scanning a very
    small part of the document. You need to read the manual and discover how to
    change the area scanned.

    With best regards, 3T39. E-mail:
     
  6. 3T39

    3T39 Guest

    Hello, 3T39!
    You wrote to John E. on Sun, 11 Feb 2007 15:00:28 -0000:

    T> If you can see a preview then the scanner is probably OK, the main
    T> issue will be software related. You are probably inadvertantly scanning
    T> a very small part of the document. You need to read the manual and
    T> discover how to change the area scanned.

    Thinking about this again, If you can't actually SEE a preview picture even
    though the scanner goes through the motions then the hardware may indeed be
    at fault. However if you DO see the preview image then it probably is
    software as I previously said. The usb connector is NOT an issue since there
    only two data lines and these must be OK if the hardware functions correctly
    ..

    With best regards, 3T39. E-mail:
     
  7. Well, except that he has the same problem when with both the Epson
    software and VueScan.

    I'd try scanning from another user account (creating a new account just
    for this purpose) and, if that fails, even trying it on another
    computer. And if _that_ fails, it's time to replace the scanner.
     
  8. Eeyore

    Eeyore Guest

    What operating system ?

    Time to reinstall the device driver ? XP often has one already available btw.

    Graham
     


  9. Use the Epson cable.

    It may have an inline device attached as do some iPod or camera
    devices.
     
  10. Arfa Daily

    Arfa Daily Guest

    No, he doesn't say that he *sees* a preview, he says that it carries one
    out - and also "scans" when tasked to do so. From this, I infer that he
    means that he hears it responding in the normal way in both cases, as the
    lamp carriage traverses the document bed. I am pretty sure that one I had
    some long time ago, just produced a blank scan when the lamp driver circuit
    failed, rather than a black image.

    Arfa
     
  11. Jimmy

    Jimmy Guest

    Use the Epson cable.
    Shouldn't make a difference if it is a standard USB cable, but if a Epson
    branded one is available he should use it. John E., don't connect into a
    USB hub, go directly into the back of the computer.
     
  12. John E.

    John E. Guest

    A bit of confusion. Sorry for miscommunicating at first...

    No representation of the document appears on the screen -- only a blank,
    white window.

    Bulb does light, and carriage moves the length of the scan bed when I click
    Preview or Scan. But no image appears.

    OS X 10.3.9, and the drivers page on Epson site says the ones I downloaded
    and installed support this OS.

    I'll try another computer, and then... we'll see.

    I was just asking the USENET world to see if there was a common, simple
    solution (whap it upside the head...) or such.

    Thanks,
     
  13. Arfa Daily

    Arfa Daily Guest

    Just for amusement, you might be interested to know that I just ditched my
    Epson all in one. I had one a couple of years back that had endless problems
    with the print heads clogging up. I like to leave my printer on all the
    time, so that when I need to print, I just click, and it's ready to roll -
    none of this waiting ten minutes whilst the thing determines if it's still
    alive, still connected, still has a driver installed, still has ink in it,
    still has paper in it and so on. Unfortunately, the Epsons don't go to sleep
    and park the heads, so if you don't print for 2 days, the stupid things dry
    out. Eventually, I got so angry with it that I went down to the store ready
    to buy a new HP, as these had always served me well in the past. I came away
    with another Epson that was such a good deal, and I figured that they had
    probably got it right on this newer all singing and dancing model. How wrong
    can you be ... I've put up with it clogging it's heads, using about a gallon
    of ink from ALL it's cartridges to perform a clean and many other foibles,
    for about 15 months, before drop-kicking it into next week, and this time,
    buying an HP as I should have done the first time. This product is superior
    in every possible way.

    I have absolutely no faith at all in Epson products, or their technical
    support people, whom I would describe as space cadets at best, and my best
    recommendation, if your problem is not easily resolved, is to just go out
    and buy another from a different manufacturer.

    Arfa
     
  14. John E.

    John E. Guest

    Just for amusement, you might be interested to know that I just ditched my
    I, too, had an Epson (850? 950?) with similar symptoms. Cleaned the heads
    right until they leaked (printed some red when you only wanted yellow) --
    ironically the opposite of the original problem (clogging).

    After that I bought the cheapest Canon I could find (iP3000 for $50US) and
    have been really happy with it. The non-US model of the Canon printers will
    print CDs/DVDs but due to patent arrangement only Epsons will do that here.
    But there is a hack to allow these US models to print now. Was that ever good
    news...

    Am prepared for the worst, and will probably go buy a Canon LED scanner if it
    comes to it.

    Thanks for your story.
     
  15. Or try any other USB cable you have to see if that does the trick - if so,
    just buy a new cable.

    Maris
     
  16. Ron P

    Ron P Guest

    Years ago I had a similar problem and had to re-install the twain driver for
    the scanner. Somehow it had become corrupted in such a manner that it
    couldn't do anything other than give a preview image no matter what program
    I used.

    If you haven't tried a re-install of the twain driver (I am assuming here
    that your scanner uses twain) it might be worth a try.
     
  17. LDP

    LDP Guest

    I have the same problem with my 1670. It was working fine less than tw
    weeks ago but now in preview mode it returns a white page just as if
    had no document on the scanner. I deleted the old drivers and softwar
    and re-installed but still same problem
     
  18. John E.

    John E. Guest

    Thus spake LDP:
    My 1670 went away with the recycle trash on Monday.
     
  19. John E.

    John E. Guest

    Thus spake Ron P:
    Thanks for your reply.

    I had reinstalled the latest drivers for it a couple of times. No joy.

    The scanner is now probably disassembled into its component plastic bits in
    the recycle yard of the local community.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-