Connect with us

Elektor EPROM Emulator flaky - continued

Discussion in 'Electronic Equipment' started by Jack, Sep 17, 2004.

Scroll to continue with content
  1. Jack

    Jack Guest

    (Response to Petrus Bitbyter in sci.eletronics):

    Original message:

    I constructed the EPROM Emulator published in Elektor magazine in the
    SEPTEMBER 1992 issue. It worked quite well under Win98, but lately I
    started using it on a HP Compaq nx9010 Pentium 4 laptop using WinXP,
    and am getting inconsistent results. The downloading of code into the
    target works successfully 1 out of 10 attempts. When the download
    fails, the download LED flickers on and off. When the download was
    successful, the LED stayed on continuously.

    Any ideas? I tried changing the parallel port mode on the laptop to
    Output Only, Bidirectional, EPP and ECP but no change.

    Thanks

    -------------------------------------------------------------------------------

    Follow-up:

    I might be referring to the wrong Elektor article - the article I
    referred to is the one NOT using a Windows driver, i.e. I download my
    object code using a DOS command line copy command in binary format
    i.e.

    copy <8051 object file> lpt1 /b

    Regards
     
  2. Captain Rick

    Captain Rick Guest

    I use a parallel port PIC programmer and had problems under XP with
    the programming mode continually being reset (LED's flashing!). This
    registry hack fixed it for me. It seems XP continually polls the
    parallel port and this interferes with other uses.

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Parport\Parameters]
    "DisableWarmPoll"=dword:00000001

    Please let me know if it cures your problem - I will add it to my list
    of "known cures" :)

    Rick.
     
  3. Clarence

    Clarence Guest


    Gee, the differences in the OS are likely the problem. XP requires you to use
    system calls to access any peripheral (port) and tries to guard against any
    program accessing the Ports directly. Frankly I do not know how to correct
    this. It is built into the OS.

    I may be wrong. But this was the explanation I got when I tried to run a couple
    of my older programs under XP. I run them in the DOS mode now and they work.
    But I don't know anything about your download program, so your still short
    enough information to solve your problem.
     
  4. Clint Sharp

    Clint Sharp Guest

    As an aside to this, are you aware that most Laptops and many desktop
    machines are only 3.3v parallel ports.... if the interface on the
    Emulator isn't 3.3V compliant, it may also cause problems.
     
  5. Jack

    Jack Guest

    Thank you for all the useful responses, which I only managed to read
    on Monday morning!

    Over the past weekend, I probed the Centronics STROBE line going into
    the emulator using an oscilloscope. Suddenly the code downloading
    process was more reliable whilst the 'scope was connected! I replaced
    the 'scope with a 10k resistor to ground and was able to download more
    consistently.

    I would suspect that the 7407 buffer on the strobe line might be
    faulty, but I will first check out the registry setting issue as well
    as the 3.3V issue. I will feed back results ASAP.

    To Clarence - I am using the DOS command line binary copy to LPT1 to
    load the object into the emulator.

    Jack
     
  6. Jack

    Jack Guest

    Some feedback:
    I tried the registry setting change, but this did not have any effect.
    I checked the Centronics voltage levels from the laptop, and it seems
    they are indeed 3.3V levels. However, the 7407 specs indicate minimum
    high voltage of 2V, so it should be able to handle a STROBE line at
    3.3V.
    I will replace the 7407 (and maybe also try out a 74LS07).
    Jack
     
  7. Jack

    Jack Guest

    I replaced the 7407 buffer with a 74LS07 buffer, but this did not have
    any effect.

    I guess I will now have to fall back to putting a high value resistor
    between STROBE and ground (on the output side of the buffer) - this
    seems to have worked last time I tried it...

    Any other recommendations would be appreciated...

    Jack
     
  8. Jack

    Jack Guest

    I soldered a 10k resistor between the Centronics STROBE line (on
    output of 74LS07 buffer) and ground, and now code images are being
    downloaded into the emulator without problems.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-