Connect with us

Electronics AutoVolt Common problem. HELP

Discussion in 'General Electronics Discussion' started by neil joseph esteban, Jul 3, 2017.

Scroll to continue with content
  1. neil joseph esteban

    neil joseph esteban

    2
    0
    Jul 3, 2017
    Hi guys,

    Someone help me on finding out what is the problem for an electronics appliance (like LCD monitor, Electronic PowerSupply, etc)
    example (LCD Monitor) when I use 110v source either not power up or the screen flicker but in 220v it's working fine.

    Objective
    find the problem
    what may cause the problem

    parts on electronic device will be affected..
     
    Last edited by a moderator: Jul 3, 2017
  2. duke37

    duke37

    5,364
    772
    Jan 9, 2011
    There is no fault, the device is designed for 220V and 110V is just not enough.
     
    neil joseph esteban likes this.
  3. neil joseph esteban

    neil joseph esteban

    2
    0
    Jul 3, 2017

    thank you but the device is autovolt to 110v-220v
     
  4. duke37

    duke37

    5,364
    772
    Jan 9, 2011
    You need much more details on the faulty equipment. If it is a switch mode supply, at a high input voltage the input capacitor has to stand a high voltage. At the lower voltage, the input capacitor has to stand a much higher ripple current. Is it up to the task?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-