Connect with us

DSE Set Top Box: G7659

Discussion in 'Hobby Electronics' started by Phil Allison, Apr 5, 2006.

Scroll to continue with content
  1. Phil Allison

    Phil Allison Guest

    Hi to my pals here,

    In October 2005 I bought myself a DSE G7659 STB.

    It worked like a charm for 17 months or so. Then, it began to misbehave just
    as the Commonwealth Games was being broadcast from Melbourne - first just
    a few pixellations, cracking noises and the odd audio muting. This soon
    became much worse and affected all digital channels.

    It *had* to be the STB and it was exhibiting the same symptoms reported by
    others on usenet.

    Once on the bench and open, I probed the various rails coming from the
    MPS - a separate module on its own PCB.

    The 5 volt rail showed a bit more HF noise than I expected but all voltages
    were OK. I left it powered off overnight ( no AC supply) and the next day
    the symptoms were drastic, ie no pic at all !

    This time the 5 volt rail measured only 3.4 volts with even more HF noise
    than before - I reckoned that would stop the processor in its tracks all
    right.

    With the aid of my trusty Bob Parker ESR meter, it was soon clear that both
    the 1000uF, 10 volt electros ( Asiacon brand) on the 5 volt rail had gone
    high ESR - to about 1.5 ohms each !

    New ones tested only 12 milliohms and were soon installed and that fixed the
    5 volt rail very nicely and returned the unit to full operation.

    The PROBLEM with the G7659 SMPS is that all the electros are tucked under
    an L shaped heatsink that runs hot - circa 75 C even with the box in free
    air.

    The easiest, permanent fix is to install a 40 mm, 12 volt, 0.6 watt fan
    blowing onto the heatsink. The wiring loom from the SMPS to the main PCB can
    be easily broken into to access the +12 volt rail and 0 volts.

    The full 12 volts not necessary fro the fan and as little as 8.5 volts does
    the trick as far as cooling the heatsink is concerned. This involves fitting
    a series resistor of about 100 ohms and an electro across the fan of
    220uF - without the electro the fan may not start on power up.





    ........ Phil
     
  2. Phil Allison

    Phil Allison Guest


    ** Err - make that October 2004 .....



    .......... Phil
     
  3. My Thomson DTI500AU STB runs *damn hot* too, esp on the botton side,
    too hot to touch the metal base plate. Always been worried about it,
    but it does only get switched on when I'm using it, so I can at least
    sleep well at night :->
    Does the fan noise cause a problem?
    Those things can be really distracting.

    Dave :)
     
  4. Phil Allison

    Phil Allison Guest

    "David L. Jones"

    ** No.

    At 1 metre from my unit, the fan's noise is inaudible.

    SPL measures approx 26 dBA.




    ........ Phil
     
  5. Ralph

    Ralph Guest

    I also bought one of these units. It worked for 13 months and then got more
    and more pixelation and freezing.
    I turned it of for a day and then it would not even display the menu.
    Thanks to you Phil, I replaced the capacitors you mentioned and it is now
    back in action.
    I now need to find a small quiet fan to install as you have suggested.
    Thank you for your posting.
     
  6. Phil Allison

    Phil Allison Guest

    "Ralph"

    ** I used a "Sunon" KD1204 PFS2 -8

    Rated at DC12 V - 0.6 W

    From David Reid Electroncics in York St.

    Came with a heatsink plate for cooling a CPU which I discarded.




    ............ Phil
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-