Connect with us

Digital Dash Fried???

Discussion in 'Troubleshooting and Repair' started by BrownDog, Nov 1, 2013.

Scroll to continue with content
  1. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    I have this digital dash of some Chinese motorbike, hyosung I think, anyways I'm currently attaching it to my car and I was trying to find the wire for the temperature sensor and dropped the speedo wire on the positive of the battery and well now it cactus

    Now it turns on for a few seconds and then turns off and stays , also a chip on the board gets scolding hot (it actually cooked my fringer a bit). Once the chip cools down again it starts again until it heats up. I did put it in the freezer overnight and it lasted a couple seconds longer.

    What did I fry and how can I fix it, can't really afford to buy another one so if I could repair this one that would be good

    Than in advance
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,499
    2,839
    Jan 21, 2010
    It's the third thing from the left starting at the flux capacitor. Just below the thronomister and between the two dark emitting diodes.

    Perhaps if you could provide a picture, pointing out the thing that is getting hot we could be a little more specific...
     
  3. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    lol. sorry wrote that up lastnight because i couldnt sleep and was just thinking, anyways heres a picture the chip in question is the biggest one there

    [​IMG]
     
  4. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,499
    2,839
    Jan 21, 2010
    Can you show me where the spedo wire connects, and can you identify the chip that is getting hot. My guess is that it's the one in the lower right corner that is not completely visible.

    Then take a closeup of the board near where the spedo wire connects and around the chip that is getting hot.

    You need to take the photo from directly above the board, and do it outdoors in shade without a flash.

    The chip that is getting hot is likely to be either a regulator (because of another chip that is drawing way too much power) or a damaged chip. However there are many other possibilities.

    If we can figure out what the speedo wire is connected to on the board, we might be able to guess what has been damaged.
     
  5. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    the chip that gets hot is in the centre of the board its the sqaure one, getting a few pictures now
     
  6. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,499
    2,839
    Jan 21, 2010
    Oooh, that's not good...
     
  7. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    can it be fixed
     
  8. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    anything that has S/P next to it
    [​IMG]

    [​IMG]

    heres the chip that gets hot
    [​IMG]

    outlined the speedo track in red
    [​IMG]
     
  9. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,499
    2,839
    Jan 21, 2010
    1) Do you remember what I said about flash?

    2) What do you mean "anything that has S/P next to it"? I need to know what the wire was connected to that accidentally came in contact with +12V

    3) That big black square thing is a microcontroller. Yes it can be easily replaced. However, it has a program on it that you cannot easily replace (you can probably not replace it at all). If that part is dead, this is probably a total loss.

    There is still a chance that the microcontroller was not actually damaged, but something else was and it is that which is drawwing excessive current from the uC causing it to heat up.

    Is there any other chip which gets hot?

    Can you trace where the wire to the speedo goes on the board. Is that something other than the microcontroller?
     
  10. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    yeah i know what u said about the flash, however tis a rather poor day over here and its too dark to no use one

    on the board in a few photos there are some metal rings that say S/P that line goes to the speedo wire

    yes there is another chip labeled D12

    the last photo has the speedo line traced

    the board is hard to follow as its two sided
     
  11. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    the D12 chip is more directly connected to the speedo wire than the microcontroller

    i think its more of a diode than a chip
     
    Last edited: Nov 2, 2013
  12. BrownDog

    BrownDog

    15
    0
    Apr 30, 2013
    i just swapped the D12 chip with the D11 and nothing has changed so maybe the fault is before this chip
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-