Connect with us

Detect AC Power supply

Discussion in 'Power Electronics' started by steve_venkat, Nov 8, 2018.

  1. steve_venkat

    steve_venkat

    27
    0
    May 22, 2017
    This is the circuit I' using to detect the AC voltage.I can't get any output from this circuit..
    Is simply in Idle.Their is no negative voltage is detected.
     

    Attached Files:

  2. Alec_t

    Alec_t

    2,487
    642
    Jul 7, 2015
    You can't get a negative voltage out, since the '814 output transistor is only connected to a +5V supply.
    What AC voltage are you trying to detect? 110V mains?
     
  3. kellys_eye

    kellys_eye

    4,289
    1,143
    Jun 25, 2010
    With 100k resistors I'm surprised you're getting anything at all. This means only 0.5mA through the opto's LEDs. Without referring to the data sheet (coz I can't be bothered to download one) is <1mA sufficient to activate the LEDs?
     
  4. steve_venkat

    steve_venkat

    27
    0
    May 22, 2017
    Its connected to MCU input,The resistor is connected as pull-up resistor...
    Have to detect 230VAC,But the voltage will vary from 160VAC to 280VAC...
     
    Last edited: Nov 9, 2018
  5. steve_venkat

    steve_venkat

    27
    0
    May 22, 2017
    Its 5mA current required.?If the voltage is constant(230VAC) means 4.k OHM is enough for it..?
    But the voltage will vary from 160VAC to 280VAC...
    At this point how to choose the resistor value..?
     
  6. kellys_eye

    kellys_eye

    4,289
    1,143
    Jun 25, 2010
    The current range for LED operation can vary considerably yet still allow it to work. Take the average AC voltage (220V) and use that to calculate the required resistor for 5mA current flow. Any changes either side of that will be acceptable.

    Alternatively take the 230V as the 'working value' and choose a resistor for that.
     
  7. Bluejets

    Bluejets

    2,976
    577
    Oct 5, 2014

    Attached Files:

    • ps.jpg
      ps.jpg
      File size:
      64.7 KB
      Views:
      1
  8. steve_venkat

    steve_venkat

    27
    0
    May 22, 2017
    The
    The LED in optocoupler is 20mA current and 70mW power dissipate.So I calculate resistor value for 5 different range of input supply and took average value from that.Its 11.1K,2W...Is this Correct method or have to change something..?
     
  9. steve_venkat

    steve_venkat

    27
    0
    May 22, 2017
    The optocoupler working fine with ground supply...I tried with positive voltage instead of ground supply and connected the output from the optocoupler to controller.Their is no response in the controller.Is this circuit is correct..?
     

    Attached Files:

  10. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    24,860
    2,571
    Jan 21, 2010
    On the optocoupler side, I would make the 1k resistor 10k, and connect it from the emitter to ground. The emitter should be connected to the microcontroller input pin.

    upload_2018-11-25_17-56-50.png
     
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.