Connect with us

Denon AVR4800

Discussion in 'Electronic Repair' started by Joust, Mar 4, 2007.

Scroll to continue with content
  1. Joust

    Joust Guest

    I've got a problem with my Denon AVR4800. it will not play digital
    content on the LEFT main channel. even internal test tone does not
    come out there.
    it got bumped around a bit so it could be a loose board or even
    cracked but how do you get into this thing? it has a lot of connectors
    on phenolic boards. I'm afraid to break them taking them out.
    any ideas?
     
  2. Meat Plow

    Meat Plow Guest

    If you don't have the manual dexterity, experience, or confidence to do
    a visual trouble shoot then take it to someone qualified.
     
  3. Joust

    Joust Guest

    Why bother replying if you have nothing usefull to say?
    I am a qualified tech, I have not worked on these units before
    though. I am used to FR4 boards. Is there a special tool you need to
    pop the boards out of thier connectors?
     

  4. You're the tech, you tell us.


    --
    Service to my country? Been there, Done that, and I've got my DD214 to
    prove it.
    Member of DAV #85.

    Michael A. Terrell
    Central Florida
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-