Connect with us

Denon AVR-X500 repair!

Discussion in 'Troubleshooting and Repair' started by hamidilyas, Aug 27, 2017.

  1. hamidilyas

    hamidilyas

    2
    0
    Aug 27, 2017
    Hello Guys,

    So my Denon AVR-X500 AV receiver started giving me weird problems like no sound from some of the channels and intermittent video display problem and then suddenly it died on me about a month ago.

    It would turn on, do a system check and with a sound of a TICK, it would turn off itself with red blinking light. This was probably because of the safety circuit on board. Anyway, since I am not of a technical guru when it comes to electronics, I gave the set to someone for repair.

    The guy worked on it for quite some time (around two weeks) and then told me that one of the IC is faulty on the HDMI digital board. He took out the IC and the set came back to life but now there's no sound. The IC is CIRRUS LOGIC CS42528-CQZ which is a DAC as well as S/PDIF converter. This IC is not available in Pakistan and I would most probably be required to import it from either China or Dubai.

    Now the receiver is giving display, and all of the menu options are working, but no sound. even when I try to do the test tones.
    What I want to confirm from the gurus is that whether this would happen i.e. no sound if you remove this IC from the board? even no test tones?

    I think I can get the IC quite easily from abroad but if this is something not confirmed, I might get some help to import the complete HDMI board. Any suggestions from where I can get this board?
     
  2. kellys_eye

    kellys_eye

    4,281
    1,144
    Jun 25, 2010
    Can you post pictures of the power supply board? I'm not even sure we can help you here as unless you can make the tests and repairs we suggest then you'll have to hand it over to another competent person to do it for you - and if they are truely competent they could/would be able to fix it anyway....
     
  3. hamidilyas

    hamidilyas

    2
    0
    Aug 27, 2017
    Thank you for your reply sir...

    One of the main reason I came here looking for an advice is that I am not aware of electronics repairs but maybe my general common sense is allowing me to somewhat understand the issue and then try and put up a question to probably get an opinion.

    Talking about the power supply... it is working for sure and I can say this because the set is turning on just fine. It was not turning on before the technician pulled off the DAC chip from the hdmi board which makes me believe that this was indeed the culprit as advised by the first COMPETENT person.
     
  4. kellys_eye

    kellys_eye

    4,281
    1,144
    Jun 25, 2010
    Replacing the IC is the obvious answer then. Without it you get zero sound. I suspect the only way you'll get a replacement board would be to salvaged one from a second set - they do come up on auction sites regularly:

    http://www.ebay.co.uk/itm/Denon-avr-x500-/172610589572?hash=item2830649384:g:ev4AAOSwTM5Y49BS

    and at that price (assuming no one else bids on it!) you'll probably find it to be cheaper than any board that an OEM supplier might offer. It would, obviously, also be simpler just to replace the set at that price!

    Sourcing spare components from overseas is still the easiest and cheapest way to fix it though - assuming the labour charges aren't onerous.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-