Connect with us

Dead Asus X550e Battery pack

Discussion in 'Troubleshooting and Repair' started by Braeden Hamson, Sep 25, 2017.

Scroll to continue with content
  1. Braeden Hamson

    Braeden Hamson

    220
    13
    Feb 18, 2016
    Hey guys, the battery in my laptop ASUS X550e shows 0% battery and is not charging. I pulled the pack out, and the cells have good voltage so they're not the issue. The issue is the charger/output board, I'm wondering if anyone has any experience or ideas of what to trouble shoot. Also according to my DMM temp setting the thermocouple is displaying an accurate temperature.

    (P.S I don't really have time to play the Google game today so sorry if there's an obvious answer out there.)
     
  2. kellys_eye

    kellys_eye

    4,276
    1,146
    Jun 25, 2010
    PS - I have better things to do than work for you.......

    sheesh....
     
  3. Braeden Hamson

    Braeden Hamson

    220
    13
    Feb 18, 2016
    Haha sorry, not what I meant. I was wondering if anyone had any ideas of were to start. Past experience and such
     
    Last edited: Sep 26, 2017
  4. dmccoyks

    dmccoyks

    23
    0
    Sep 26, 2017
    I would start with checking the power port. These laptops are know for these plugs either breaking the center pin or coming loose,from the board
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-