Connect with us

Configuration of HMR2300 Magnetometer

Discussion in 'Datasheets, Manuals and Component Identification' started by hmz2017, Aug 11, 2017.

  1. hmz2017

    hmz2017

    3
    0
    Aug 11, 2017
    Hello,
    I am trying to configure a Honeywell Magnetometer in Hyperterminal using a serial usb connection. No data is returned after a successful connection is established using a COM port. I have tried various other programs such as Labview and PuTTy and Matlab. I have attached the datasheet for the component for reference. Any help would be appreciated
    Thank you,
    Hamza
     

    Attached Files:

  2. kellys_eye

    kellys_eye

    4,284
    1,145
    Jun 25, 2010
    Try a different USB/serial lead. There are known issues with some type of serial converter leads that prevent full communication.
     
  3. hmz2017

    hmz2017

    3
    0
    Aug 11, 2017
    The sensor communicates via the demo program that comes with the product. However, the demo program is very basic as it cannot be used to send commands to the sensor or change its settings to different frequencies (e.g 60Hz). Therefore, I am trying to use Hyperterminal as mentioned in the products datasheet, as a means to establish a connection and change the frequency it is functioning on.
     
  4. hmz2017

    hmz2017

    3
    0
    Aug 11, 2017
    It should be noted that the product communicates successfully with the "Demo software" and I am using the same serial port for data transfer. If it displays data in the demo software it should be able to display data in hyperterminal as well, however that is not the case. I tried playing around with the baud rate as well and I was not able to get any readings in hyperterminal
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-