Connect with us

citizen vcr/tv combo power comes on then goes off after 2 sec

Discussion in 'Electronic Repair' started by Ronaldo Nogueira, May 19, 2004.

Scroll to continue with content
  1. Hello everyone,

    A friend gave me this VCR/TV combo made by Citizen model JCTV1595. It would
    be Ideal for a course on VHS tapes I'll be taking. The problem is when I
    turn it on the power comes on and dies after 2 sec. I've open it and found a
    broken belt on the vcr part fixed and the mechanical parts are working
    because if I apply power to the motor the tape goes in comes out wthout
    problems. I've look for bad capacitrs or other electronic problems but have
    no schematic to follow. Any one had this problem before? Anyone knows where
    to get the schematic for a resonable price?

    Thank for any help.

    Ronaldo
     
  2. Patch

    Patch Guest


    When you power it up, do any motors try to run?
     
  3. The motor does not try to run and I turn it on with a multimeter on the
    motor terminal and it had no voltage there but the high voltage works for
    short period of time because I can hear the picture tube sarting to work.
    thanks,
    Ronaldo
     
  4. jakdedert

    jakdedert Guest

    I've got one which 'tries' to run--picture comes up while whirring sounds
    emanate--then whole thing shuts down.... As it was donated, I haven't
    opened it up yet, but thought to first investigate the mode switch, then
    limit switches and, if no joy, the gear timing.

    I take it this is a common occurance on these? What's the secret? I have
    an additional parts set....

    jak
     
  5. jakdedert

    jakdedert Guest

     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-