Connect with us

Canon Copier PC720 Clangy Noise

Discussion in 'Troubleshooting and Repair' started by CalGirl, Dec 16, 2016.

Scroll to continue with content
  1. CalGirl

    CalGirl

    2
    0
    Dec 16, 2016
    sudden problem with Canon Copier PC720

    clunky clangy loud nose, now paper does not go through it.

    purchased new Fall 1997. Not used lot, just home copying when needed, and it has always worked perfectly with absolutely no problems.

    Today, I copied something successfully, and was copying another page and red symbol indicating Paper Jam... I opened and added paper. Also opened main part and checked for any jams. Then I closed the lid and the red signal was OFF. The other lights were normal.

    I thoroughly checked for any paper jam and there is none.

    The red signal now went off.... I pushed to copy, and a big noise came on. I re-checked paper load, lessened it a bit... to no avail. Still a big clangy type noise.

    Then I tried the manual feed with a piece of paper and noise just clangs. Powers on and off normal, other things are normal looking.

    I love this copier, and hoping its an easy fix. I am hoping for suggestions of what is going on and if I could fix this. I have no mechanical abilities though. Thank you.
     
    Last edited: Dec 16, 2016
  2. KTW

    KTW

    273
    15
    Feb 22, 2015
    Sounds like a mechanical failure, unplug it and give it a good cleaning but at 19 years of age I'd say you were due a new machine.
     
  3. CalGirl

    CalGirl

    2
    0
    Dec 16, 2016
    I found an answer on another forum to this question... it made sense to a certain point then I got lost... I am able to find the little spring hanging there, but cannot see where it came off or where it goes, or what broke. I believe the weather cold snap caused something to break off, it was in an unheated room about 30 degrees... I do not want a new machine., I want to fix this. I just can't figure out where the little hook spring hooked onto in the first place ...

    This was from another forum --

    Question --- I have a Canon Copier PC720. It reports a paperjam, however; I have looked high and low through the copier and cannot find a paper jam anywhere. Is there some way to reset the fault report?




    Answer:

    The problem with the paper jam (but not feeding) is that a small piece of plastic that holds one end of a spring the causes the feed gears to push against the powered gear on the back side of the toner cartridge breaks off.



    So the unit does not feed (no pickup rollers etc) and it thinks there is a paper jam (no moving paper).



    Orienting the front as the side you work at, the back being the back, the feed being the side the paper goes into and the output being the side the finished copy comes out, open the unit.



    Looking into it from the output side almost to the input on the bottom notice the small hairlike things sticking up. Move to the left (back of the machine) and see a few white gears all hooked into this gray metal housing that moves up and down about 1/2 inch (It pivots).



    At the top input side of this metal you will see a part of the metal that stick up and has a small slot in it. the spring used to hook onto this and the other end hooked to a small piece of plastic down and more to the input side a bit, onto the upper input side of the white plastic part that houses a shaft to a roller (fat little spring about 1 inch long). the plastic part breaks off and you usually can't see that a part was even there.



    The spring will still be in the area. If you are handy, you can figure out how to fix it. I got a longer spring (same strength) bent the metal toward the back 1/4" and ran the new spring from there to a 1/16 hole I drilled in the plastic side next to the circuit board (down low and back). I shaped the end of the spring (where I drilled) to keep it more inside and not hit anything.

    Also check the paper feeding roller and the transport roller to see if they are worn out due to aging.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-