Connect with us

cannot write to EEPROM

Discussion in 'General Electronics Discussion' started by Fairface, May 21, 2017.

Scroll to continue with content
  1. Fairface

    Fairface

    1
    0
    May 21, 2017
    So I tried to build a simple manual EEPROM programmer to program the chips just by switches. I am able to read from the chips (all outputs are 1), but I am not able to write into them by bringing notWE low and than high again (while notOE is high). When I set it to output it outputs all ones at the IO pins as before no matter what I try to program into it. I have tried 3 different EEPROMs with the same results. I have also tried to disable the software data protection, but nothing has changed. I have measured the voltage on all pins few times and it all seems to be fine (voltage around 5,04V). I am using the AT28C256-15PU datasheet: http://ww1.microchip.com/downloads/en/DeviceDoc/doc0006.pdf
    Has anyone experienced something similar? Any ideas why is this happening?
     
  2. Bluejets

    Bluejets

    4,219
    894
    Oct 5, 2014
    Circuit diagram?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-