Connect with us

Camera Canon G1 not working

Discussion in 'Electronic Equipment' started by Taylor, Mar 11, 2012.

Scroll to continue with content
  1. Taylor

    Taylor Guest

    I have two Canon cameras, a G1 and a G2.
    The G1 wasn't used for about one year and when I tried to charge the
    battery it didn't respond. Absolutely dead.

    Since they used the same battery and the same charger, I tried the
    charged battery and the G2 charger . No results.

    The G2 works fine but the G1 doesn't respond.
    Shell I arrange for a funeral ?

    John
     

  2. John-

    I have the G11. There is a "Troubleshooting" section near the back of
    the owner's manual. For your symptom, it only says to be sure the
    battery is fully charged and inserted correctly. Check your camera's
    manual to see if there is something else specific to your model.

    Some models have a second battery (or high capacity capacitor?) inside.
    Its purpose is to maintain the clock and setup memory while the battery
    is out of the camera for charging. Over time, the camera's battery
    self-discharges, and this internal battery will also run down. In case
    that has happened to your G1, it may self-correct if you keep a fully
    charged battery in it for several hours.

    One Canon EOS DSLR had a separate lithium cell inside for the same
    purpose. It should last for several years, but eventually needs
    replacing.

    Fred
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-