Connect with us

Ballast fault

Discussion in 'Troubleshooting and Repair' started by Michalis georgiou, Feb 13, 2017.

  1. Michalis georgiou

    Michalis georgiou

    7
    0
    Feb 13, 2017
    Hello there, i want help with a ballast fault,

    I did wrong connections between L and N and my lamp isnt opening! Do you know if my ballast is burned or its only to change a burned part of it!?
     
  2. Minder

    Minder

    2,801
    583
    Apr 24, 2015
    Did you blow the tube starter filaments at all?
    M.
     
  3. duke37

    duke37

    5,189
    704
    Jan 9, 2011
    Interchanging L and N should not affect the operation. Please state what you did wrong. Show a picture.
     
  4. Michalis georgiou

    Michalis georgiou

    7
    0
    Feb 13, 2017
    What do you think by this connections? I did it like the electrical diagram and still sot lighting up
     

    Attached Files:

  5. Bluejets

    Bluejets

    3,360
    670
    Oct 5, 2014
    What is the lamp and what is it's rating?

    Balast shows compatible with High pressure sodium or metal hallide 400w.

    Also wondering if you have ever been around when one of these lamps implode?
    Obviously not given your test set-up.
     
  6. Michalis georgiou

    Michalis georgiou

    7
    0
    Feb 13, 2017
    MH Lamp 400w , i did the connections like the diagram but still not working, my cable is 1,5 mm2 and its okay as i know because of the 1,7 amperes . 400w= 230v * 1,7 amps


    What do you think i did wrong?
     
  7. Michalis georgiou

    Michalis georgiou

    7
    0
    Feb 13, 2017
    I didnt open my ballast at all , but i will when i find where is the broblem, do you think that ise the starter or the thermostat?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-