Connect with us

B&K Precision Power Supply

Discussion in 'Electronic Design' started by John O'Flaherty, Sep 7, 2006.

Scroll to continue with content
  1. We bought a B&K 1788 programmable power supply, that claims to be
    0-32V/0-6A. When we tried to use it, we were never able to get more
    than a couple of amps out of it, under any load. When we tried to run a
    DC motor on it, it settled on a current of about 1/2 A, at about 1V,
    not enough even to turn the shaft. Putting a 3ohm resistor across it,
    programming for 10V and 3A, we should have gotten a constant current of
    3A at a voltage of 9V, but got 2.46V at 0.81A. With a 9.1ohm load,
    setting voltage for 24V and current for 3A, we got 11.68V at 1.31A.

    Finally, while running the motor with a 3ohm resistor in series, it
    ran at 24V and 1.49A with the shaft free-running. Putting a finger load
    on the shaft, the current increased to 2.5A, and then a relay in the
    unit clicked and the voltage dropped back to 15V. Around then, it
    started emitting epoxy-smelling smoke.

    Although the unit is spec'ed at 32V, it can't even be programmed to
    that- anything higher than 31V gets trimmed to 31 on the display.

    Has anyone here used this supply, and found it not to be a piece of
    shit? I'd like to know if we should return it for warranty repair or
    try to get our money back.
     
  2. It's what's known as 'faulty'. Don't condemn the design because you have
    a moribund sample, not even a 'Friday afternoon' sample. Talk to your
    supplier - politely. At least, politely to begin with. (;-)
     
  3. Joerg

    Joerg Guest

    Hello John,

    Epoxy-smelling smoke? My advice: Return it, asap.
     
  4. Trevor

    Trevor Guest

    We bought a BK Precision 1760A a few years ago. When I unpacked it, I
    heard something rolling around inside. So I took the cover off and
    found 2 or 3 small screws that had likely come loose during shipping.
    After locating the places where thay came from, I replaced them, closed
    the unit up, plugged it in and it has worked just fine ever since.

    Cheers,

    Trevor Leger
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-