Connect with us

Armada 7400 Charging Problem

Discussion in 'Electronic Repair' started by Cliff M, Dec 9, 2004.

Scroll to continue with content
  1. Cliff M

    Cliff M Guest

    I would love some feedback on an old PII compaq laptop. Until recently it
    worked great, but now it will not charge properly. It's a Compaq 7400 PII
    366 running XP and the Compaq battery utility. It runs fine on the ac
    adapter and it will run on the battery, but the battery will not charge
    above 18%. If I let the battery discarge it will shutdown when it gets too
    low, and will start to charge when I plug it in, but only to 18%. I have a
    second matching 7400 and I have tried swapping batteries and ac adapter but
    to no avail...what works fine in one armada does not work in this one. I
    have read lots of info on the web about broken laptop power sockets and this
    seems to be a possibility but I don't want to tear it apart while it is
    still working except for the charging. Any tips or trouble shooting ideas
    would be great!

    Thanks in advance,

    Cliff
     
  2. cmdrdata

    cmdrdata Guest

    Cliff, I think your battery is bad. I think your battery is Li_Ion, and
    most laptop are powered by six Li_Ion cells in pairs (each pair
    generates 3.6V). In your case the smart charging system has detected
    the cells are no longer able to reach full state, hence the 18%. Get a
    new one from eBay ( cheapest route). Rebuilding is not an options as
    the cells are expensive and not guarantee that the programmable memory
    within will recognize it as having new cells. Also, cell pair matching
    is needed and most people will not have that capability/tool.
    (Speaking from experience with my thinkpad 366 MHz batteries). I've
    been through the above route).
     
  3. But I have two matching Armada 7400s and this battery wil charge to 100% in
    my second machine . Also the battery from that second machine will not
    charge in my problem machine. Actually the symtoms are similiar, but not
    identical....

    One battery will charge normaly to 18% (but no further), and machine runs
    great on AC. Will also run fine on battery, but not for long.

    Second battey causes the on screen charge indicator to flicker on and off,
    and the screen will flicker in brightness as if it's switching back and
    forth between battery and AC power.

    Neither battery is NEW, but both batteries charge normally in second
    machine. I agree that I would like to try a NEW battery just for grins, but
    does that still seem a likely solution?

    Thanks much,

    Cliff
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-