Connect with us

Arduino UNO + 2.8 tft white screen

Discussion in 'Microcontrollers, Programming and IoT' started by AlenZGB, Mar 1, 2018.

  1. AlenZGB

    AlenZGB

    170
    4
    Feb 19, 2014
    Helloo

    I have UNO with https://www.velleman.eu/products/view/?id=435582
    2.8 tft velleman display and i get white display.
    i manage to use one library and on tft.begin(0x9341); if i dont use 0X9341 the
    picture wont come. Drivers should be ILI9341 acording to web page for that screen that i bought.

    Im trying to make my friend a nice tachometer for his piaggio porter something like this one on the
    link here
    Needle one.

    Any help would be nice .

    Thanks in advance.
     
  2. kellys_eye

    kellys_eye

    4,281
    1,144
    Jun 25, 2010
    Is your wiring correct?
     
  3. AlenZGB

    AlenZGB

    170
    4
    Feb 19, 2014
    I dont have wires i just plug the LCD on my UNO board, cant connect it any other way around.

    i found this video, thats how i fix it but only for that library, i want to know what can i do so that other libraries work with my screen too.
     
  4. kellys_eye

    kellys_eye

    4,281
    1,144
    Jun 25, 2010
    Libraries are device-specific and simply swapping different size screens can stop them working due to individual register differences. If your screen isn't EXACTLY the same as the one the program is addressing then you'll have to check for those 'differences' and make the relevant adjustments.
     
  5. AlenZGB

    AlenZGB

    170
    4
    Feb 19, 2014
    Im guessin that will be to hard to explanin in few words. :(
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-