Connect with us

Arduino problem

Discussion in 'Microcontrollers, Programming and IoT' started by r2d2, Apr 28, 2013.

Scroll to continue with content
  1. r2d2

    r2d2

    7
    0
    Apr 21, 2013
    I had asked for advice earlier in this forum, and was suggested to get an AVR-ISP programmer.
    I got one, and then following the parts near the ending of the guide here : http://arduino.cc/en/Main/Standalone
    I tried burning the bootloader, but it ends up giving me this error : avrdude: stk500_getsync(): not in sync: resp=0x80
    My AVR-ISP programmer is attached on a USB port, using a serial to USB converter, and is shown as being attached to COM8.
    I tried changing the direction of the uC, but that didn't help either, and I got the same error again.
    The shop I bought the programmer from blacked out the address of the website on the board, so I do not know anything at all about it. Thats pretty bad of them.
    I am including a few photos below of the programmer attached to the board below, hopefully that'd help.
    [​IMG]
    [​IMG]
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,499
    2,839
    Jan 21, 2010
    A few things to try:

    1) try AVR ISP Mk2

    2) make sure the pinout of the cable actually coincides with the required pinout (I have one that needs to go in the reverse way to what you think)

    3) make sure you have the correct arduino chip selected.

    4) hold down the shift key while you try to program the arduino. You'll get better error messages (well, you'll get more detailed ones).

    5) try with the board you're programming on powered and unpowered.

    6) refere to the "correct" connections for an AVR-ISP programmer and make doubly sure the right pins are being connected to.
     
  3. r2d2

    r2d2

    7
    0
    Apr 21, 2013
    I would not be able to get AVR ISP mk2 where I live.
    The pinout is right, the wire is made in a way that makes it impossible to put it the wrong way, it has a higher block of plastic on one side.
    I swithed from AVR ISP to Arduino as ISP and my error changed to : avrdude: stk500_getsync(): not in sync: resp=0x3a
    AVR ISP and powered on : avrdude: stk500_getsync(): not in sync: resp=0x80
    AVR ISP and powered off : avrdude: stk500_getsync(): not in sync: resp=0x00
    My programmer is attached to com8.
    Arduino as ISP powered off : avrdude: stk500_getsync(): not in sync: resp=0x00
    The uC is an AtMega16A. The board selected is Arduino Diecimila or Duemilanove w/ ATmega168
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-