Connect with us

Amstrad DRX300 (No remote function)

Discussion in 'Electronic Repair' started by Jack00, Apr 12, 2008.

Scroll to continue with content
  1. Jack00

    Jack00 Guest

    I've got this digibox which does not respond to the Sky remote but if
    this remote is tested on another digibox then it works fine. But if i
    press the front buttons on the DRX300 digibox then it seems to work
    but with the remote nothing happens. Any help appreciated.

    Thanks
     
  2. Arfa Daily

    Arfa Daily Guest

    First, if you haven't already, you need to do a full power-down reset.
    Unplug from the wall for at least 10 minutes. If still no joy, follow this
    with a forced software update. If still no joy, then it's time to get the
    lid off, and dust off your 'scope to check what's coming off the remote
    sensor. If you don't have a 'scope, then you won't get very far tracking
    down the problem, if it is a 'real' fault.

    Arfa
     
  3. N_Cook

    N_Cook Guest

    Beware the mains voltages can be relatively exposed in such boxes , when the
    cover is removed

    Just a crystal (not magnetic) earpiece will probably tell if the remote
    receiver is working.

    connect one wire of the earpiece to the outer metal of a phono or coax
    connector on the rear, the other then touch to each of the traces going to
    the receiver block in turn.
    Usually 3 traces,
    a/ would stop the stray pickup noise on an open earpiece (ground)
    b/ would just give a click on touching (supply V)
    c/ would give a varying click noise on pressing buttons on the handset.
    (signal line)

    NB No stray wires that could bridge other traces, just neat single wire for
    probing.

    If more than 3 going to the receiver block then try each in turn , one
    should be variable click, related to keypad presses.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-