Connect with us

amp distortion

Discussion in 'Electronic Repair' started by bigtom, Apr 26, 2005.

Scroll to continue with content
  1. bigtom

    bigtom Guest

    KENWOOOD KA-31 Amplifier

    the left channel on this amp sounds distorted at lower volume and cuts
    out at med to high volume.
    i tried swapping the speakers but its definitely the amp
    ive esr'd the caps on the main board but theyre ok.
    there are 4 big transistors on heatsinks and 4 small ones next to them
    they all test ok on a dmm set to diode test(readings are not exactly
    the same, but close)
    what should i be looking at first?
     
  2. uh, maybe an oscilloscope?

    Leonard
     
  3. Mark

    Mark Guest

    probably an open transistor,

    did you take them out of the circuit to test them?

    are there any large resistors like 0.47 Ohms near the output
    transistors, check them for opens also


    Mark
     
  4. Solder connections, relay contacts, speaker switches...

    Maybe a transistor has an open junction.

    A 'scope would help. Often these types of problems are intermittent, and
    pushing, poking, tapping around can lead to a suspect...

    Mark Z.
     
  5. bigtom

    bigtom Guest

    found it, open junction on one of the small transistors (C556)
    had to take it out to test it properly.
     
  6. Dave Moore

    Dave Moore Guest

    : found it, open junction on one of the small transistors (C556)
    : had to take it out to test it properly.
    :

    One trick is to look for approx .65 volts on the
    base emitter junctions while the unit powered up.

    Almost all of the transistors in most "vanilla"
    SS power amps will be biased "on",
    so, you can usually expect to see this forward junction
    voltage on almost all of the transistors except for the
    two over-current protect transistors which would be
    biased off in the abcense off an output over-current
    protect condition.

    This sort of check probably would have sniffed
    out that open junction




    :
    : Mark D. Zacharias wrote:
    : > bigtom wrote:
    : >
    : >>KENWOOOD KA-31 Amplifier
    : >>
    : >>the left channel on this amp sounds distorted at lower volume and cuts
    : >>out at med to high volume.
    : >>i tried swapping the speakers but its definitely the amp
    : >>ive esr'd the caps on the main board but theyre ok.
    : >>there are 4 big transistors on heatsinks and 4 small ones next to them
    : >>they all test ok on a dmm set to diode test(readings are not exactly
    : >>the same, but close)
    : >>what should i be looking at first?
    : >
    : >
    : > Solder connections, relay contacts, speaker switches...
    : >
    : > Maybe a transistor has an open junction.
    : >
    : > A 'scope would help. Often these types of problems are intermittent, and
    : > pushing, poking, tapping around can lead to a suspect...
    : >
    : > Mark Z.
    : >
    : >
    :
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-