Connect with us

Altium Designer 6 multilayer routing problem

Discussion in 'CAD' started by [email protected], Mar 31, 2007.

Scroll to continue with content
  1. Guest

    Hello everybody,

    Problem description:
    I have a 4 layer + 2 power plane mixed-signal PCB with SMD components
    on one side and I would like to route the digital signals on Mid Layer
    1+2 and the quiet analogue signals on the Top and Bottom Layers.

    Altium version: Altium Designer 6.7

    Layer Stackup Buildup (no blind and buried vias)
    Top Layer
    GND Plane
    Mid Layer 1
    Mid Layer 2
    Power Plane
    Bottom Layer

    I placed the digital signals in a 'Digital' Net Class to be able to
    assign a routing layers rule to these digital signals - routing layers
    enabled for this rule are Mid Layer 1 and 2. Priority=1.
    The analogue signals where also allocated to an 'Analogue' Net Class
    and assigned to another routing layers rule with the Top and Bottom
    Layers enabled. Priority=2
    I also have a default rule with all the routing layers enabled.
    Priority=3.

    Behaviour:
    For some reason when I run an Auto Route->All the signals in the
    digital Net Class are not routed. Signal fan-out vias are generated
    but then the connections on the inner layers are not made. It's not a
    problem of the router not having enough space to route the signals,
    the router simply stops. I could try to route the signals by hand but
    there are too many of them and it's clearly not the point of using an
    autorouter.

    When I try to route the 'Digital' Net Class separately by going to
    Auto Route->Net Class... the same problem happens (on a board with no
    pre-routes). The autorouter doesn't do anything. Running an Auto Route-
    Strangely enough if I replace the fan-out vias with pads and then I
    run Auto Route->Net Class... the connections are made.

    Am I missing something, or is this a bug?
    Hope somebody out there is able to help!

    Best regards,
    Patrick
     
  2. Patrick,
    I would be suspicious that the rule only allowing digital signals in the
    mid-layers is jamming up the autorouter. Because the signals actually
    originate on the top or bottom layer, even though you have fanned them out
    already. Does that make sense? The vias probably are not seen by the router
    as a valid starting point for routing, it is likely looking right back to a
    pad to start the autoroute, thus when you changed them to pads then they
    seemed to route.
    So I would suggest routing it with the fan out vias changed to pads,
    afterward change them back to vias and lock those routes or don't reroute
    the digital net class again.
     
  3. pacikk

    pacikk Guest

    Hi Brad,
    thanks for the reply. I think you're right about the fact that the
    problem is caused because the signals originate in the top or bottom
    layer, since when the routing layer on which the signals are
    originating is enabled the autorouter finishes successfully. The idea
    of switching the vias in question to pads to enable successful routing
    is certainly a solution.

    Yesterday I did some more experiments and found another method. I
    discovered that if I locked these fanned-out vias the autorouter also
    routed the nets in the digital class. Maybe the reason for this
    behaviour is that once the autorouter sees that these vias have been
    locked it shifts the signal origination point to these vias.

    I wonder how other board designers are handling the design of mixed-
    signal pcbs in Altium. I thought routing noisy digital signals on the
    inner layers was the standard way of routing mixed-signal PCBs.

    Regards,
    Patrick
     
  4. Hi Patrick,
    Your methodology is perfectly sound, routing the digital signals on
    inner layers. Alternatively though one could argue that properly routed,
    impedance matched and terminated digital signals should not be noisy
    anyways. At least not where they would cause violations of any EMI
    regulations.
    Obviously locking the preroutes is the answer to the issue. Prior to
    locking those preroutes the autorouter is undoubtedly reasoning it's routing
    based upon shifting back to the pads on either the top or bottom layers.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-