Connect with us

altec lansing imt702

Discussion in 'Audio' started by sira, Nov 27, 2018.

  1. sira

    sira

    11
    1
    Nov 27, 2018
    Dear members

    I got above item with out power adapter. some one may have used different power adapter and now it docent switch on. original power adapter should be 13 V bit i used 12V 2A . seems some thing burned in site. just replaced zennor diode - 8.2 V and no luck. please let me have your valid advice on this

    Thank you
     
  2. Tha fios agaibh

    Tha fios agaibh

    1,920
    601
    Aug 11, 2014
    Show a clear picture of board on both sides and perhaps we can assist.

    As long as the 12v adapter had the proper polarity and current (ac or dc) it shouldn't have caused any damage.

    If you can post a schematic diagram, that would also help.
     
  3. sira

    sira

    11
    1
    Nov 27, 2018
    Hi Tha
    thank you for the reply. unfortunately i too do not have the Schematic diagram. i searched all over the internet and couldn't find it. i have some pictures for your reference

    https://imgur.com/a/LjwkVWZ


    [​IMG]
     
  4. Tha fios agaibh

    Tha fios agaibh

    1,920
    601
    Aug 11, 2014
    It's hard to see detail of components in pictures, but here's what I'd do.

    First verify you have the proper power adapter and polarity. Read the back panel where it plugs in to verify.
    Then follow the point where it inters the board. Is it the black and red wires on the edge of board?

    Look at markings on the board in this area to see if there's a surface fuse (usually begins with letter F) that may be out. You can put one meter lead on the Neg side of your power supply which is usually the same as chassis ground. Then take the other lead to measure the positive side along the path where power comes in. You can also check for continuity it theres no power.

    Make note of the voltages along this path and where you no long have voltage and the component in question.
    Hopefully its something simple like a fuse or diode along this power path.
    You can Google "how to test a diode" for more info.
     
  5. galaxy

    galaxy

    28
    2
    Nov 3, 2012
    What's that large black thing with what looks like a toasted resistor next to it?
     
  6. sira

    sira

    11
    1
    Nov 27, 2018
    Hi all
    It looks the system IC gone. i checked all the power source to each IC and seems ok. I just thro it away. how ever looking to buy Altec lansing M402SR from some where and it looks hard to find . thank you
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-