Connect with us

All white raster on Sony Wega TV

Discussion in 'Electronic Repair' started by Sparky, May 5, 2007.

Scroll to continue with content
  1. Sparky

    Sparky Guest

    This TV was working before we recently moved it -- without dropping the
    175 lb beastie! Now with no inputs the raster is all white instead of
    all black as it used to be. The brightness and picture controls (as
    well as all of the other menu items) appear to operate and display normally
    but the background raster remains a saturated white instead of black as it
    used to. Unlike the main picture, the PIP picture has reasonable contrast but
    it has no color, only black and white. You can see a just a tiny bit of
    detail in the main picture. Since the PIP picture displays video and I have a
    raster, I'm looking for problems in the luminance path for the main picture,
    not the CRT grids or anything else CRT related. Looking at the schematic
    makes me suspect that the PIP control is shot but all else is likely okay. Any
    opinions on what may be wrong with the TV and where I might be able to source
    a replacement circuit board?

    Thanx!

    Russ
     
  2. Guest

    You are not going to source a replacement circuit board. The tv needs
    troubleshot and repaired to the component level.
     

  3. Since you say it was dropped, I'd look for cracks in the cirucit board and
    also look for cracked solder joints.

    - Mike
     
  4. The mystery is that the TV malfunctions now but was NOT dropped during
    the move. Pulling the back of and tapping everything inside didn't
    expose any connections that are sensitive to mechanical vibration. More
    troubleshooting to follow as I get the time...
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-