Connect with us

alba CX540XI/s BOOMBOX BLEW IC CHIP

Discussion in 'Troubleshooting and Repair' started by groovejet, Oct 12, 2014.

Scroll to continue with content
  1. groovejet

    groovejet

    53
    1
    Feb 27, 2011
    our boombox we use for work has had a little hickup!
    We! Well myself to be honest wired up a 12 v1.5ah battery to the battery connections on the back, as i didnt have a 240v lead to get some tunes going to lighten the day.
    All that happend was a humm coming through speakers and the smell of burning components....Ooops.

    So now that our emergency boombox has seen better days i want to try and fix this thing.
    Ive stripped it down and couldnt see anything , so i put power to it, waited 2minutes and a IC chip started smoking.
    Before it burnt to badly so it was unreadable i wrote down the code: KT2206B / QAF523.
    Looking on the net, they dont seem to be the easiest component to purchase.

    Anyway , with this kind of fault is it normal for surrounding components to be knackered also?
    What would be the best way to go forward?.....Solder in new IC and see what happens?
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,384
    2,771
    Jan 21, 2010
    First things first. Did you wire the battery backwards, or was it designed for a voltage other than 12V?

    Second thing. Can we have some photos.

    Third thing. If the device is connected to power now, does any part of it operate?

    Depending on what you did, you may have damaged far more than just the one chip. The failure of that chip or any other component can cause other failures.

    The KT2206 looks like it's just an amplifier. Even if you can't get a direct replacement, you may be able to wire in something else if there's enough room. As to whether that's the only failure though...
     
    KrisBlueNZ likes this.
  3. groovejet

    groovejet

    53
    1
    Feb 27, 2011
    Thanks for reply Steve,
    1. I could of wired it backwards, and the voltage should of been 9v dc
    2. DSC0000120.jpg DSC0000121.jpg DSC0000122.jpg Sorry about pictures, using old mobile, i know there useless but better than nothing!
    3. Ive connected to 240 ac and all i get is a low pitch humm amplified through speakers. No controls work, tuning etc.

    The KT2206 is aparantly a 2.5W Dual Audio Power Amp

    I know its a piece of rubbish but id rather fix it than just through it away....Why Not???
     
  4. ramussons

    ramussons

    356
    66
    Jun 10, 2014
    That IC (KT2206) is gone. Take it out. Then power on the unit. If the lamps and motors work ( check the cassettee unit - rewind / f forward ) replace the IC. My gut feeling is that it should work. The IC would have sacrificed itself and protected the remaining :eek:
     
    groovejet likes this.
  5. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,268
    Nov 28, 2011
    Exactly. In your face, cheap Chinese crap manufacturers! Don't let 'em fill up our landfills, I reckon. Have a good try at fixing the damn thing.

    As rasmussons says, try taking the IC out and see if the rest of it seems to work. This won't be a conclusive test because you can't check the rest of the signal path; something else may be damaged.

    There's a slight problem though. I can't find a proper data sheet for the KT2206. I found a small PDF showing a typical application circuit, which I've attached to this post. If you want to replace it, you may not be able to buy it in small quantities or even in any quantity. In that case you can try to replace it with a complete assembled stereo audio amplifier board from eBay.

    If you're still keen, have a go at removing it and look up some amplifier modules on eBay and we can go from there.
     

    Attached Files:

    groovejet likes this.
  6. groovejet

    groovejet

    53
    1
    Feb 27, 2011
    Thanx guys , This forums is wicked ! The in depth info you guys go into is unreal and most appreciated.
    Ive already removed the IC and tested the tape cd and radio.

    Cd- indicator light comes on and cd spins

    Radio- Radio when turned to Fm stereo the indicator light comes on when i search for stations ( although theres no sound or interference coming from speakers as before, the chip was removed.

    Tape- This also works but no sound.

    So all in all it looks like changing the chip will sort it.

    As you said id rather fix it and have a new work radio, than chuck it in bin.

    It does look like the IC is gonna be a difficult one to find, will let you know the outcome.

    Thanks
    Paul
     
  7. groovejet

    groovejet

    53
    1
    Feb 27, 2011
    Here a pdf but it says UTC?? is it the same pin out for KT2206b ??
    Found 2 data sheets for UTC from 2 manufacturers and pin out is different on both , unless the diagram is showing a representation and not correct pin out??

    Youw Ang Pdf is the one im not sure about!!
     

    Attached Files:

  8. davenn

    davenn Moderator

    13,581
    1,868
    Sep 5, 2009
    compare it to the info Kris gave ;)
     
  9. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,268
    Nov 28, 2011
    Nice work there groovejet! The UTC2206 looks like a drop-in replacement for the KT2206.

    Both of those data sheets are for equivalent devices; the Youwang one just has the IC drawn the opposite way round - possibly in a feeble attempt to avoid a law suit from the original manufacturer. But both the UTC/Unisonic and the Youwang parts look suitable.

    Now, can you get them in small quantity?
     
  10. groovejet

    groovejet

    53
    1
    Feb 27, 2011
    Thanx Kris, you really know your nuts! Your experience is invaluable.
     
    KrisBlueNZ likes this.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-