Connect with us

aduino uno and siemens gsm serial modem

Discussion in 'Microcontrollers, Programming and IoT' started by RonKirby, May 23, 2014.

Scroll to continue with content
  1. RonKirby

    RonKirby

    3
    0
    May 23, 2014
    hi there I have siemens gsm serial modem and I am having troubles also have the arduino uno to try to interface with it

    first problem is I just cant get the siemens to register on my new win 8 computer I did manage to get it to work on wifes 3 yo Toshiba win 7 computer but not even that works now
    so I am wondering if anyone has experience with these things and can help me a bit the siemens tc 35 is from ebay (china) and looks well made I have accessed it once and send a test message with it. the software offered with the device is in chinese and I have been unable to make any of it work
    I have had to install hyper term as it is no longer available with windows 7 and 8
    any ideas or suggestions would be appreciated

    Thanks
    Ron
     
  2. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,272
    Nov 28, 2011
    Hi Ron and welcome to Electronics Point :)

    I can't help with the modem but I can suggest you use something better than Hyperterminal (i.e. anything other than Hyperterminal). In my experience, Hyperterminal causes its own problems, as well as being nasty to use. One thing that's worse than diagnosing difficult problems is diagnosing difficult problems with broken tools!

    An article on other replacements for Hyperterminal:
    http://helpdeskgeek.com/windows-7/windows-7-hyperterminal/

    These free programs sound good, though I haven't tried them:
    http://sourceforge.net/projects/realterm/
    http://www.compuphase.com/software_termite.htm
    http://ttssh2.sourceforge.jp/

    A shareware one:
    http://www.shadeblue.com/
     
  3. RonKirby

    RonKirby

    3
    0
    May 23, 2014
    hi there thanks
    well ihavnt been able to move any further so far I have xp on this computer and it cant find a port and i have a new comp with win 8 and i cant get it to do anything either
    i have an arduino uno this appears to be able to log in ok via usb but that is the limit of my advancement so far
    cheers

    edit i have d/l 2 more term progs as you suggest i will try them tomorrow
     
  4. shumifan50

    shumifan50

    579
    57
    Jan 16, 2014
    Windows is notorious for needing special drivers for devices. Linux on the other hand talks to generic chip sets mostly and therefore you might have a chance to make it work under Linux. Once you manage that, you might be able to find the required driver for Windows. I am guessing that the software included with the device includes the driver. You might try and install the software, restart the PC and see if the device appears.
     
  5. RonKirby

    RonKirby

    3
    0
    May 23, 2014
    thanks guys i have ordered new parts and try again
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-