Connect with us

ADS PowerPlate 120 amplifier power cycles on its own

Discussion in 'Troubleshooting and Repair' started by KilgoreCemetery, Apr 14, 2017.

Scroll to continue with content
  1. KilgoreCemetery

    KilgoreCemetery

    240
    11
    Apr 12, 2017
    I have this older, high quality car amplifier that didn't work when it was given to me and I've been trying to get it to work. At first, nothing would happen when I tried using it. So, I took it apart and found an exploded capacitor and burnt out diode side-by-side. There were obvious burn marks on the board around them. The good news is that I also happen to have an incredibly similar PowerPlate 80 that works fine. For the time being, I swapped out the two bad components with known working ones and ordered replacement ones.

    Now as soon as I supply the "remote" wire with 12vdc it comes on, and then turns right back off. Then on, and off, etc..

    I've already checked the fuse, and some of the other components seem fine, but a lot more of them have voltages that fluctuate.

    Upon further inspection, I did find a spot that makes me think someone else may have worked on this particular amp before (picture below). I can't tell if it has anything to do with the current problem or if it's just a previous fix.

    Despite that, I have been trying to track down where the fluctuations are originating from to no avail. Could somebody please give me an idea of what to to next?
     

    Attached Files:

Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-