Connect with us

Ademco Vista-15P cannot disarm, keypads freeze, stuck in alarm

Discussion in 'Troubleshooting and Repair' started by alegacy, Jul 16, 2021.

Scroll to continue with content
  1. alegacy

    alegacy

    2
    0
    Jul 16, 2021
    I have a wired alarm system (Ademco Vista-15P) that we inherited from the previous homeowner. We have been using it in standalone mode (i.e., no monitoring) for 2 years without issue. Last night, we were woken in the middle of the night by the alarm sounding the siren. I was a bit panicked, and in a rush to figure out if the house had actually been broken into or if this was a false alarm so I didn't actually notice what zone was being reported on the keypad. I wasn't able to disarm the system because the keypads would freeze after 4 key presses (i.e., i would put in my 4-digit code and would hear a beep on each key press, but then no sound was made when I pressed the OFF button...and then no further key presses made any beeping sound). The siren continued to sound so I disconnected the AC power and the battery.

    Since then I powered up the system (AC only) and tried disarming it from different keypads. The same behaviour happened -- unable to disarm and keypads would freeze. I tried different user codes and my master code -- always the same result.

    On each power up the keypad displays the "dl" code for a minute or so and then shows "ALARM 107" and then cycles thru "CHECK xx" where xx is each of my zone numbers one at a time. After the initial minute or so passes the system goes back into an alarm state and sounds the alarm siren again. I disconnected the sounder from power to troubleshoot without having it blaring at me.

    I tried using the star(*) and hash(#) button method immediately (within 50 seconds) after powering up to enter programming mode but it does not enter programming mode. I also tried having my wife hold down the * and # buttons while I restored the AC power but that didn't work either.

    The keypads do respond to the 1+3 buttons to set the keypad address so it looks like the keypads are fine.

    I think the "ALARM 107" code is reference to the extender module (4219) so I unplugged it from the main panel but that didn't change any behaviour.

    None of our other electronics in the house appeared to have been reset last night so I don't think there was a power outage... maybe a brief power bump -- not sure.

    I am not sure where to go from here. I am not sure if the main panel is dead or if the extender module is dead or both. Given that I can't use the backdoor method to get into programming mode I wonder if I should even attempt to use the factory reset command.

    Anyone see anything like this before? I've seen one similar thread but that person seemed to be able to use the backdoor method to enter programming mode.
     
  2. davenn

    davenn Moderator

    13,865
    1,956
    Sep 5, 2009
    alegacy likes this.
  3. ChosunOne

    ChosunOne

    411
    119
    Jun 20, 2010
    It sounds like one of your peripheral devices (like your keypads and 4219) is garbling the data flow. They're all connected to the data lines at Terminals 4, 6, and 7 on the Vista-15P. If one device is sending garbled signals, it blocks signals from all the devices. If the system is Armed when that happens, the Panel (the V-15P) goes into alarm. The keypads, unable to get feedback from the Panel, will lock up after a few key presses.

    Look at Termimals 6 and 7 to see how many devices you have connected. You know about the keypads and 4219. There may be other devices.
    Disconnect all of them, then try reconnecing the keypads one at a time. You only need disconnect the wires at 6 &7, the data lines.
    That should get you a working keypad so you can Disarm the system.
    After you have one working keypad, re-connect the other devices, one at a time, and test to see if the keypad(s) lock up after each device.
    NOTE: I STRONGLY recommend powering down the Panel (the V-15P) while disconnecting and reconnecting power (Terminals 4 & 5) from/to Keypads and other devices. Don't connect a live wire to power up a keypad: Connect first, then power up the Panel.


    Just to check, you did disconnect both AC and battery to power the Panel down before reconnecting the AC? Assuming you did, then the original installation company may have locked up the Panel so it can't be programmed locally (Keypad Programming). You might try holding down the * and # buttons while applying AC several times, and waiting a powered-down minute between each try. Sometimes you get lucky.
    If the backdoor method absolutely won't let you into programming, the only fix is to replace the V-15P Panel, which will entail reprogramming the new panel from scratch.

    First see if you can get a working keypad, then see if you can reconnect the 4219. My guess is that the 4219 isn't causing the problem, since you already disconnected it and the keypads still locked up. You may not have to get into programming to solve your immediate problem.

    By "factory reset command", I assume you mean the *97 command, which you can only use while you're in Programming Mode. No, don't use it---since you have to already be in Programmign Mode to use it, then you don't need to. So if you can get into Programming Mode by trying * and # while powering up, several times, do yourself a favor and STAY AWAY from *97. I see a lot of people cost themselves a lot of unnecessary work by wiping program memory and having to program from scratch.
     
    davenn and alegacy like this.
  4. alegacy

    alegacy

    2
    0
    Jul 16, 2021
    @ChosunOne thank you so much for your detailed response. After a couple of hours of troubleshooting I have narrowed it down to a short-circuit in a wire running between a keypad and the V-15P control panel.

    Since the wires were tightly/neatly packed in the control panel I didn't want to get into pulling that apart to separate the data lines into their individual pairs so I started by first disconnecting the wires directly at each of the keypads and then only connecting one keypad at a time. Using that approach I wasn't able to resolve the issue.

    At that point I thought that the control panel must have been at fault, but not wanting to give up too easily I decided that I should bite the bullet and disconnect the keypad at the control panel (terminals 6 and 7) and re-connect them one at a time. Using that approach, I was able to resolve and disarm the system.

    Given that my first approach didn't work but my second did that left me scratching my head as to whether the keypad or the wiring was to blame. To double-check my results I reconnected the wires to the "faulty" keypad, but then disconnected the wires inside of that keypad (i.e., wires connected to the control panel but not the keypad). The problem returned and the panel reported "ALARM 107" on the other keypads. I disconnected those wires and put a multimeter on them to check for a short. Sure enough, there is a short between the black (negative power) and green (data-in to the keypad) wires. I am surprised that didn't kill the control panel altogether.

    Luckily that wire is sort-of easily accessible via a crawl-space so I'll have to track down that short and run a new wire. I am not sure how that could have happened in the middle of the night...other than maybe a mouse chewing on it. o_O

    The system is back up and running on both AC and battery (minus one keypad). I tested it and it goes into alarm state as expected whether I trigger a sensor. Thanks again for your help. I would have replaced both control panels and completely wasted my time/money! :D
     
  5. ChosunOne

    ChosunOne

    411
    119
    Jun 20, 2010
    Glad you were able to resolve the problem. Won't be the fisrt time a rodent trashed a wire, but you might find someone put a staple into a 4-conductor cable when it was first installed. Some problems don't show up for years, after insulation wears through from rubbing as the house shifts.
     
    PETERDECO likes this.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-