Connect with us

ad 620 instrumentation amplifier

Discussion in 'General Electronics Discussion' started by shibas, Feb 13, 2013.

Scroll to continue with content
  1. shibas

    shibas

    14
    0
    Feb 13, 2013
    Some body please reply to this thread by giving the circuit diagram of an instrumentation amplifier using AD 620 Ic.The gain required for me is 100 or some value below 100.please mention the gain equation for the particular circuit.
     
  2. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    Have you even LOOKED at the AD620's data sheet? It's full of detailed information on how to use the device, and includes lots of circuit diagrams.

    Analog Devices also have an application note on instrumentation amplifiers that might help.
     
  3. shibas

    shibas

    14
    0
    Feb 13, 2013
    i connected one circuit.but it doesnt give me the correct output.so please help me dude.
     
  4. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    I can't help with a description like that.
    What circuit did you build?
    What input did you connect to it?
    What output did you get? What's wrong with the output?
    Can you upload a photo of your breadboard?
    Measure the voltages on all pins of the AD620
    Give a lot more information.
     
  5. shibas

    shibas

    14
    0
    Feb 13, 2013
    i am sending the circuit diagram and the values of components.All details are mentioned in it.
     

    Attached Files:

  6. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    The diagram is hard to read. Use a better light source and take the photograph looking directly at the diagram.

    What's the value of RG?
    What is the reason for the 0.1 uF capacitor between the input source and the non-inverting input?
    Why are you using an instrumentation amplifier for a simple single-ended input signal? A single op-amp would be fine for this application.
    Why have you connected two capacitors across the output? This will screw up your output waveform severely.

    You haven't answered these questions from my post #4 on this thread:
    What input did you connect to it?
    What output did you get? What's wrong with the output?
    Can you upload a photo of your breadboard?
    Measure the voltages on all pins of the AD620 --- edit: don't worry about that one.
     
  7. shibas

    shibas

    14
    0
    Feb 13, 2013
    i didnt used bread board.I assembled the circuit in a pcb.value of rg i used was for a gain of 106 and its value is 470 ohm.i used the 0.1 uf capacitor before the non inverting input to remove the dc offset components.
     
    Last edited: Feb 13, 2013
  8. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    And the answers to the other questions?
     
  9. shibas

    shibas

    14
    0
    Feb 13, 2013
    Sir iam sending my circuit diagram and the values of components used in the circuit in two separate attachments.please refer to it and mention any change if i have to make to the circuit to get the amplified output.When i connected this circuit first i was not getting the required gain.But now iam getting very huge gain than the gain that is required.The gain equation for ad 620 is G=(49.4k/rg)+1. isn't it? I need a gain of about 100 or below 100.please help me sir.I used the 0.1 uf capacitor between the input signal and the non inverting input to remove the dc offset components.Is that right?
    Do i need to insert a resistor between the inverting and non inverting input terminals of the op amp and ground that resistor to reduce the effect of the input bias current?
    Some body please help me.
     

    Attached Files:

    Last edited: Feb 15, 2013
  10. Laplace

    Laplace

    1,252
    184
    Apr 4, 2010
  11. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,270
    2,718
    Jan 21, 2010
    And if you don't want to annoy the moderators you won't post three more threads (that I have just deleted) about the same topic.
     
  12. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    You haven't changed the schematic at all. It still has the problems I mentioned.

    Please read the article that Laplace referred you to. You need a DC bias on the non-inverting input of the op-amp. With only a capacitor connected to it, you will not get this.

    You still haven't answered several of my previous questions.

    A single standard op-amp, wired as a single-input non-inverting amplifier stage, would be fine for this application. Why are you using an AD620?

    Why have you connected two capacitors across the output? This will screw up your output waveform severely. It may also cause the op-amp to oscillate.

    What is your input source?

    Can you upload a photo of your circuit board? Both sides please.
     
  13. poor mystic

    poor mystic

    1,061
    30
    Apr 8, 2011
    I looked up "instrumentation amplifier" on Wikipedia and found a circuit, which only needs resistor values to be chosen in order to complete the design.
    The design consists of 2 voltage followers, one for each "leg" of the signal pair, followed by an amplifier circuit which compares the outputs of the followers.

    Power Supply
    The Wikipedia note doesn't mention that the design requires both a positive and a negative supply to the instrumentation amplifier chips, and that the earth shown in the circuit should be connected to the 0V rail.
     
  14. shibas

    shibas

    14
    0
    Feb 13, 2013
    Thank you to all.It finally worked well when i inserted a resistor of 1M ohm each(grounded) to both inverting and non inverting input terminal of the AD 620 ic.
    Also i removed the two capacitors c8 and c9 which was connected from the output to the ground.

    I designed the circuit for a gain of 105 using equation G=(49.4k/Rg)+1 using the Rg connected between pins 1 and 8 of the ic as 470ohm.
    But iam getting only a gain of about 100 or a gain value just below 100.

    Also in my output ac signal its negative half cycle amplitude is less than positive half cycle amplitude.What should i do to correct my output signal by making both half cycle amplitudes equal?

    What to do?some body please help.
     
    Last edited: Feb 16, 2013
  15. poor mystic

    poor mystic

    1,061
    30
    Apr 8, 2011
    How accurate are your resistors?
     
  16. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    I will try one more time to get you to answer some basic questions.

    1. Why are you using an AD620 instead of a standard op-amp connected as a non-inverting ampifier?

    2. What is your input source? What type of signal? What impedance?

    3. Provide a COMPLETE schematic, including details of (a) the input source, (b) the load circuit and (c) the power supply.

    4. Upload a photo of your circuit board. Both sides.

    5. Upload a photo of the oscilloscope traces for the input and output signals.

    If you can do this, there's a chance that I, or someone else here, will be able to solve your problem.
     
  17. shibas

    shibas

    14
    0
    Feb 13, 2013
    My application is to amplify the signal output from a vibration sensor or vibration analyzer which is comparatively very less.For that will opamp ic 741 connected in non inverting configuration be suitable?
     
  18. KrisBlueNZ

    KrisBlueNZ Sadly passed away in 2015

    8,393
    1,267
    Nov 28, 2011
    The 741's gain-bandwidth product (GBP) is 1.5 MHz so with a gain of 100 it's usable up to a maximum of 15 kHz. If the highest frequency in the signal from the vibration analyser is much less than 15 kHz, then you can use a 741, if they're still being manufactured!
     
  19. shibas

    shibas

    14
    0
    Feb 13, 2013
    741 0pamp ic amplification problem

    Iam using a vibration analyzer or sensor.I need to amplify the above sensor's output signal.For this purpose i used opamp ic 741 in the non inverting configuration.But when i gave the input to the amplifier from a function generator the amplifier gave a gain of about 50 and 68 initially.When i changed the input frequency from the function generation to 1 khz amplifier gave a gain of 100 even though the amplifier circuit was originally designed to give a gain of about 101.

    But for my application,when i give the input to the amplifier from the output of the vibration analyzer the gain of the amplifier circuit changes to a huge value of about 450.

    What may be the reason for this?

    At first i used AD620 ic for the amplification instead of the op-amp ic 741.The behaviour of the gain at that time was also similar to now.

    Somebody please help and reply fast.
     
  20. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,270
    2,718
    Jan 21, 2010
    Please show us the circuit diagram.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-