Connect with us

3kw inverter repair

Discussion in 'Power Electronics' started by Stockleys, Jun 18, 2019.

  1. Stockleys

    Stockleys

    2
    0
    Jun 18, 2019
    Hi all
    I need some advice with regards to repairing a pure sign wave inverter

    I have a new spwm. (EGS002)
    4 new IGBT’s and all new associated resistors and diodes

    The spwm is getting a good 5v and 12v
    The IGBT’s are getting a good 380vdc

    When powering on, I can hear the transformers buzzing for 3 seconds and I get a peak of 8vac from the output. After these 3 seconds, the spwm shuts down and flashes the low voltage code (not that I need it to know that 8v is far too low)

    Why am I not getting 230v even tho the IGBT’s are being fed with 380vdc?

    I’m really at a loss
     
  2. Tha fios agaibh

    Tha fios agaibh

    1,901
    599
    Aug 11, 2014
    Probably something on driver board isn't firing your gates. Perhaps ir2110s or related components. Did you check all your diodes?
     
  3. Stockleys

    Stockleys

    2
    0
    Jun 18, 2019
    I have replaced all IGBT’s diodes and resistors. Iv has 3 new spwm control boards the first wouldn’t give an output. The next 2 blew a pair of IGBT’s each.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-