Connect with us

32" Toshiba TV problem

Discussion in 'Electronic Repair' started by Robotron Tom, Nov 26, 2004.

Scroll to continue with content
  1. Robotron Tom

    Robotron Tom Guest

    I have a Toshiba 32" TV about 6 years old.

    The problem is that when I switch it on, I hear the normal "coming on"
    sound but it does not come on. No picture, no sound. It's the same with
    remote or button on the set itself. I looked and no light from the
    heater. It did come on, once after the set had been unplugged for about 3
    months, but hasn't since.

    Is there a component I should investigate, like a relay?

    Thank you,
    --
    Robotron Tom *remove nospam to email*
    See the Flashback Arcade at: http:// www.arcadeguy.net

    Standing for right when it is unpopular is a true test of moral
    character.
    -M. Smith
     
  2. RonKZ650

    RonKZ650 Guest

    It's usually a bad 4.7uf capacitor in the power supply. Look for a red colored
    capacitor near the smps transformer. It causes the power supply output to be
    high, and the set will shut off immediately if it's bad.
    Ron
     
  3. Robotron Tom

    Robotron Tom Guest

    RonKZ650 started a controversy when he said... :
    I will get right on it.

    Thank you very much for taking the time to answer my question.

    --
    Robotron Tom *remove nospam to email*
    See the Flashback Arcade at: http:// www.arcadeguy.net

    Standing for right when it is unpopular is a true test of moral
    character.
    -M. Smith
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-