Hitachi model 27AX1BC

Discussion in 'Electronic Repair' started by François, Jul 23, 2004.

  1. François

    François Guest

    Hi,

    I have a problem with an Hitachi model 27AX1BC. When TV is plugged, a high
    hiss comes from
    T901. I have changed STRD6602 (IC901) with no change. There is no voltage on
    relay coil RL901 resulting
    in no click. Also, IC901 comes very warm.

    Does anyone know what the problem is?

    Thanks in advance,

    Marcel Noël
     
    François, Jul 23, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sidney

    27" Hitachi tv model:TN-77000,chassis:G9LXU

    Sidney, Sep 28, 2003, in forum: Electronic Repair
    Replies:
    1
    Views:
    599
    Jerry G.
    Sep 29, 2003
  2. Angela D'Andrea
    Replies:
    5
    Views:
    2,768
    Shoreline Electronics
    Feb 21, 2006
  3. User99
    Replies:
    1
    Views:
    402
    Mwwcam
    Dec 22, 2003
  4. gudule

    Needed YOKE HITACHI model TS-3610

    gudule, Jan 13, 2004, in forum: Electronic Repair
    Replies:
    0
    Views:
    292
    gudule
    Jan 13, 2004
  5. Sidney

    20" Hitachi tv model:CT2033B,chassis:FH89XS-2

    Sidney, Mar 4, 2004, in forum: Electronic Repair
    Replies:
    0
    Views:
    620
    Sidney
    Mar 4, 2004
Loading...

Share This Page